Missing Drops and Achievements

On my last ride the drops and achievements I was awarded in the game have vanished. The ride saved and uploaded okay, it even shows up on the companion app, but when I log in they are missing. I’ve contacted support but no answer. I have a screenshot of ride in the companion app but when I press the button to add that to this thread I get treated to a frozen blue zwift screen (iOS) :roll_eyes:

I thought I had more drops than when I started riding today, but ignored it. Then when I finished my ride, expecting to complete the Everest challenge, and I’m down about 270m of climbing!!! The Everest challenge only showing that I’d done 33m instead of 335m! Fuming.

1 Like

Same problem. There is another thread with a few people having the same issue.

For me, last night I completed Alpe du Zwift for the first time. Earned a bunch of drops, the achievement for Tour of Ice and Fire and the KOM Gloves. When I finished the ride, the gloves and the achievement were gone and I had less drops than when I started.

On Apple TV 4k and using companion app on iOS - all latest OS and app software installed.

I started a help/tech support ticket. Hopefully I hear back and this can be fixed.

3 Likes

I am having the same problem.
These last 2 weeks, this problem happen to me.

Rides shown in Strava and my.zwift.com, however level progress, xp, drop, badges all are not saved.

Come on Zwift, fixed this problem. What’s the point of gamification, if we keep losing our hard earn achievements ?!

3 Likes

Well said! It’s surprising not to get any response from customer service after such a long period of time…

Any resolution? I’m having the same issues.

There may be other issues at play here, but is everyone making sure to follow the advice given in the thread linked above? I.e. If you’re on ATV, make sure you are force-quitting the app after every ride. Also, whatever system you’re on, make sure you are not logged in on multiple devices. These two situations (ATV issue and being logged in on multiple devices) can cause weird local/temporary bugs.

1 Like

I’m running on a PC with Zwift open only on the computer. Zwift exits on it’s own at the end of the session when I end the ride so nothing else to “quit”. No response from support via email, chat or phone call. Currently missing ~100K drops. Switched to Mt. Everest challenge instead of California mid ride and now showing NEGATIVE progress on Everest.

Chris

I’m going to uninstall and reinstall on the PC to see if that fixes it. I’ll post up with results.

Uninstalled, reinstalled - same result. Worth noting that my “best ride data” at ride start is all 0s as well, screenshot from yesterdays ride (tempo) showed that every category was “best” from that ride, which I know to be untrue.

do you have a file share program like dropbox taking all the files from your documents folder and syncing to the cloud or something? Zwift stores some info in the documents folder too, and I wonder if that is the root of your issues.

1 Like

No dropbox, onedrive, box or any others. It’s a dedicated Zwift computer. I am getting an “Auxiliary controller failed to connect to socket” on exit. Looks like it was an actively denied connection. I’m going to dig into Windows defender to see if they turned something on in the last update…