MilestonePod( Zwift RunPod) speed detection (Intervals)


(Arkadiusz Andruszkiewicz) #1

I have a problem with speed reading from MilestonePod. It does not detect higher speeds (intervals). I include two files from the same gear on the treadmill. Both * .tcx one of MilestonePod, the other Hrm-Run garmin.
Any idea? Advice?
MilestonePod V3 software.

edit:
I’m sorry, I do not know how to add files :frowning:

edit:
Link google: https://drive.google.com/open?id=1mpGyBBt7AKB193ycVzCVeeAGbg6OYmCN


(Vincent W.) #2

Hey there, can you explain a little bit more what the Milestone Pod is not detecting? It detects slower speeds and but stops reading accurately as you go faster? Can you try calibrating your pod?

Here’s some steps on how: https://www.milestonepod.com/faq/how-do-i-adjust-calibrate-my-session/


(Arkadiusz Andruszkiewicz) #3

Thank you for your response,
Attach * .jpg which illustrates the problem.
Garmin correctly detected the change of pace, Milestonepod did not detect.


(Zach Johnston) #4

Ive used the Fenix 3 (and now fenix 5) for the past four years. I can guarantee that once its calibrated to your stride, your fenix will ALWAYS be way more accurate than a $30 pedometer.

I also use the Milestone pod, but I only use it for Zwift interface, not for data collection.


(Arkadiusz Andruszkiewicz) #5

That’s exactly what my charts show.

I expect that Pod will be at least similar (I expect this :wink: )


(Ch Christensen) #6

Hi all

I experienced the same issues…
The milestone pod has been calibrated around my average running pace 11.5-12km/h.

If I run below this speed zwift/milestone indicates a higher speed than the treadmill.
eg: 10km/h on treadmill is 11km/h on zwift/milestone.
Running above and well above eg. 14km/h will only show 12.5… to 13km/h on zwift/milestone.

In general calibration on target pace helps…
however the more the running pace deviates from the calibrated pace, the bigger the gap.
As a general rule, more than 1km/h difference to the calibrated pace provide unsatisfactory results…

Overall milestone seems not practical for serious training.
Even relying on heart rate will be much more accurate.


(Arkadiusz Andruszkiewicz) #7

Not suitable for training purposes.
To analyze the results, it is also unsuitable.
But it really kills boredom :slight_smile:
And It shows well cadence.


(Christoph Kehrer) #8

I got the same issues that you guys have! Of course I was not expecting a precision instrument for 40$, but my old Garmin foodpod is much more accurate and in the same price range.
The Milestone is more a kind of cadence or “running technique” detector, because when running on the treadmill at constant speed and increasing cadence, the indicated speed will go up significantly. Even is cadence is almost contant and you change your body position ever so slightly or just the height of your backswinging foot, the speed will change!
As all the data just comes from an acceleration sensor, my old Garmin is of course also suscepticle to cadence changes (using the same technical principle), but the algorithms in that pod seem much better. The pace change will normally be around 10 seconds/km maximum! Whereas the Milestone will be up or down by 2km/h or even more!

I have calibrated so many times and even tried to calibrate with outdoor GPS data, but during intervals I’m still off by around 2km/h, which can be annoying, as it does matter whether you run 10x400m or 10x 460m!

The three step calibration also only works in one out of three times for me. Maybe because the sensed speed from the pod seems to be to low, even if the treadmill is set correctly?! If I do the intervals at 16,6km/h (about 5:47min/mile), the pod will indicate 14.5km/h (6:37min/mile). So during the third calibration interval I might often not be in the range, that the calibration will accept as coorrect and subsequently terminate the calibration process.

I have three possible solutions for this:

1.) Above a certain speed that is selected for calibration, it should not only be three steps, but four, five or even more (maybe even user selectable?!) to increase the range of calibrated speeds.

2.) If only using three steps during calibration, the “spread” of the three selected speeds should increase with the selection of the initial speed.
I.e when selecting 10 km/h, the calibration should be at 10, 8, and 12 km/h
When selecting 12km/h, speeds sould be 12, 8 and 15 km/h
Of course it is just meant as an example and not as exact figures…

And during this process, the range of speed, that is accepted as being correct, should be larger than it is up to date, avoiding nuisance calibration aborts.

3.) Maybe as a final (and golden) solution, the algorithms in the pod itself should be updated, so they are no longer as sensitive to cadence changes as they are right now.

Happpy running,
Chris


(Arkadiusz Andruszkiewicz) #9

In my opinion, this is not a matter of calibration.
The case concerns Milestonepod. MPod misses the speed, it can be seen in the charts that I sent.
You must update the Pod software, the calibration would be unnecessary.

Arek