Zwift Run Pod Calibration Issue

I am using the Zwift run pod on my treadmill. After doing the calibration, it seems to be dialed in almost dead on (+/- 0.1 mph) at my cruising speed of 8.0mph, but when I try to do speed work pushing to 9.0 or higher mph, the speed in Zwift goes all over the map, usually dropping to anywhere from 5.5 to 7.5mph and never going up anywhere near my actual pace. It seems to suddenly be missing a bunch of strides leading to it thinking it is a slower pace. Anyone else having this kind of issue or know a way to correct it? I’ve tried playing with my stride while going at the faster pace and nothing brings the zwift pace anywhere close to the treadmill speed.

It’s pretty common I’m afraid. The run pod is rapidly becoming regarded as the most problematic and least accurate of the options out there.

Is there a good recommendation of what would be better? My treadmill isn’t set up to connect directly, so I am looking for something along the lines of a run pod.

The NPE Runn is pretty good although the speed can be constantly fluctuating around you target speed so is distracting.

Theres an app called treadmill speed transmitter which you basically tell how fast you’re running and it sends out to Zwift. If you change speed on the treadmill you have to click + Or - in the app to match.

The best option is the QZ Domyos app which can read the speed from your treadmill if it is BT enabled and sends this to Zwift. This means you change the treadmill speed and Zwift matches it. Under certain circs it’ll automatically change incline too.

There is the stryd footpod also. Deadly accurate in most cases. Pretty expensive however.

Funny…it worked brilliantly outside when it was originally a Milestone Pod…(what it was designed for). I still use mine and its perfect outside.