Zwift runpod three point device calibration

Hi all, hope someone can help me out with a calibration problem ? I’m struggling to get the Zwift app to follow the full three point calibration process on my run pod. The App is running on an up to date IPad, and a new Zwift run pod with a fresh battery. I use the treadmill for mainly walking with some light running, so operate at lower speeds. When following the calibration process, I set the normal speed at 6.4kph and perform part one of the process for forty seconds. The process then automatically skips the lower speed calibration without and input from myself. It then moves to the higher speed calibration for forty seconds, and then ends the process declaring the calibration a success. As I tend to walk/run at lower speeds, this then leaves the Zwift speeds being wildly inaccurate. To a degree that is understandable as the calibration hasn’t processed the lower speeds, as they were skipped.
I’ve tried deleting and downloading the app again, and also a hard reset on the runpod by removing and replacing the battery. I’ve tried over and over, but it keeps skipping the lower speed calibration.
Am I doing something wrong in the calibration process, or is it a Zwift issue in the calibration within the app ?
Any help or advice would be much appreciated.

Hi @Hwyl_Thomas welcome to Zwift forums.

I have heard from my running colleagues that where you attach the pod to your shoe can have an effect. They recommend attaching the pod as far forward on the laces as you can. Would you try that and see if it helps in your situation?