Milestone Pod + Zwift + 3-part pod calibration problem


(Clifford) #1

Hi there,

I have a Milestone Pod that I want to use to record my runs on Zwift. Before my attempts at the Zwift calibration process the pod was reading 1 to 2kph high compared to my treadmill’s reported speed.

I attempted to calibrate the pod, but got constant disconnect messages and was unable to get through the process without erroring out. I did manage to sneak one in, but now Zwift is reporting that my speed is 5 to 6kph higher than the treadmill is reporting!

I updated the Pod to the latest firmware and reset it’s calibration by removing and re-adding it to the Milestone app and while the disconnect messages are way less frequent, I still cannot get through the calibration process. The difference is that now, instead of dropouts, I can get through the first two run segments of the calibration, but when I get to the 3rd faster segment Zwift keeps telling me to adjust the treadmill speed to the required speed, but it’s already at that speed. That situation persists until the calibration process errors out.

I am now unable to use Zwift to run. Help?

Cheers,
Cliff


Pod no funciona
(Vincent) #2

Hey Clifford, have you tried troubleshooting with Milestone’s FAQ here? https://www.milestonepod.com/get-help/faqs/


(Zach Johnston) #3

I actually just had the exact same experience right after the Companion update. I updated the milestones firmware, restarted my phone, and went from there and got a successful calibration. However, it’s now far less accurate than it was, I had it nearly perfect before. :confused:


(Clifford) #4

Yup. The problem doesn’t seem to be with the pod. It’s Zwift that has the issue.


(Eiki Egilz) #5

Hi there @Vincent

I have the same problem with Stryd now, after the new 3-part pod calibration (or the latest Zwift update on Apple Tv 4k, not sure … but either one ). After I used the new calibration Stryd always tracks at 0,4 - 0,7km/h less than the treadmill is set to. So when the treadmill is set to 12km/h, Zwift will say 11,3 - 11,6km/h … before it was 100% SPOT ON, always. Is it possible to get back the 1-part pod calibration back? Or can I somehow restore the old settings … ?

Kind regads,


(Eiki Egilz) #6

Hey again @Vincent, issued FIXED :slight_smile:

What I started wondering is WHEN this started to happen, that is WHEN did the Stryd
begin to behave this bad, because it was DURING a session this started to happen.
It was when the Stryd began to run out of battery! After that I’ve re-calibrated the
Stryd against my treadmill again ( again, using the 3 point calibration ) … but that did NOT fix the problem.

What I did, was a simple RESTART of the Apple Tv 4k :slight_smile: When I restarted it, and opened up Zwift again,
the Stryd is again, 100% SPOT ON!!! So you might due this “trick” guys, if the Stryd runs out of battery,
WHILE you’re doing an exercise ( it becomes innacurate on the last 2-3% of battery I would say ) and you start
to have these out-of-sync between Stryd and your treadmill inside Zwift, which a battery-recharge up to 100%,
does NOT fix … try a simple restart. You won’t even have to re-calibrate I think, although I did that.

Just wanted to let you guys know, hope this helps someone. Stryd is BACK … 100% SPOT ON ( I only tried 10, 11 and 12 km/h though since I’m going to work now
and don’t have more Stryd/Zwift time now :slight_smile: )


(karl cannell) #7

Is the new zwift footpod just a rebrand of the milestone footpod or does it have new hardware ?


(Arkadiusz) #8

Yes, it’s just a rebrand.
I have the best results when I do not do any calibration. If I do the calibration, the difference between treadmill and MilestonePod is about 2-3km / h


(eric thomas (V)) #9

I couldn’t get to the correct firmware version from milestone, but it updated some. I tried calibrating with the milestone app but didn’t have the opinion to calibrate. Tried with zwift and can get the first 2 parts done, but not the 3rd. Seems it thinks that if I am at 180 spm, my speed is .5 to .8 mph faster than what my garmin foot pod was saying on my watch.


(Steve Copeland) #10

You calibrate the milestone in its own app not in Zwift.


(eric thomas (V)) #11

I tried that, it didn’t work


(Andrew Sheppard) #12

Hi all, i have been experiencing similar issues with my milestone pod and i contacted them direct about it. they say they are aware of this problem and there is going to be another Zwift update published this week to correct it. Hopefully this is the case!

Since the latest Milestone app update (last week) it now tells you (in the app) to calibrate in Zwift and not in the Milestone app. Hope that helps once they have fixed the bugs!