Message "No Ant + Dongle"


(scott crandall) #1

I’m not sure why Zwift thinks i dont have an ANt+ Dongle…I do have one installed and it is working with Trainerroad. So i press ok and then the screen for searching for devices appears and when i select to search for power meter it doesn’t find it. I tried taking out and re-installing the dongle but no luck. Any suggestions?


(Kevin Drisko) #2

I have two, well maybe three or four, ANT+ sticks but it is only the one that says USB2 that works with Zwift. Not sure if that is your problem, but thought I would suggest it.


(Stewart G teamWBR) #3

Have you set TR to the trainer relay setting? This should let Zwift find this signal. You might need two ANT sticks for it to work though.


(Eric C. (Zwift HQ)) #4

Hi Scott,

Make sure it is USB 2.0 and that you’re not running any other software that may use the ANT+ dongle while running Zwift.


(Christian Lyra) #5

Are you using OSX? or Windows?


(Jamie Bray) #6

i have exactly the same problem on OSX - ANT+ dongle works with TR but cant pick up HR on Zwift.

was working perfectly until about 2 weeks ago…

both TR and Zwift on same machine


(Eric C. (Zwift HQ)) #7

FYI: Zwift needs a dedicated ANT+ dongle (separate of whatever other programs you decide to run concurrently, which we do not support :wink: )


(Jamie Bray) #8

no programs being run concurrently, problem still exists when ONLY zwift running and no other application, have removed and reinstalled the software, same problem. :frowning:


(Eric C. (Zwift HQ)) #9

We really haven’t changed any code in regards to how Zwift handles ANT+ signals. Make sure there is nothing else transmitting wireless signals or, perhaps, just try pairing your HRM in a different location if possible.


(Christian Lyra) #10

I asked about OSX because I had that problem. But my case was something not usual. The filesystem was case-sensitive (you can check with disk tool) which is not the default, and Zwift could not find the ANT+ dongle because of this. The Zwift programmer team is aware of it, but no fix yet. If this is your case, there’s a alternative solution (somewhat technical).


(scott crandall) #11

I thank you for all the responses.  Luckily all it took was rebooting the computer.  I am on a Mac computer and Zwift has worked fine the handful of rides i’ve done.