Can't pair powermeter after update


(Joachim Sjogren [Sz]) #1

Today i started zwift and it automatically updated, And now I can’t pair my Power2Max.

I have used zwift about 15-20 times and it has worked perfectly everytime, until now. I tried with trainerroad and that works fine.

I’m on a Macbook Pro with El Capitan


(Jon Mayfield) #2

Sorry to hear that. Can you try unplugging your ANT dongle, and replugging it in, then start up Zwift?  It’ll reboot the ANT driver on MAC and often that’ll allow devices to be paired again.

We didn’t change any ANT device pairing in this update so it may just be a coincidence.  


(Joachim Sjogren [Sz]) #3

I’ve tried unplugging my ANT, rebooted the computer a few times, re downloaded the software (i think, it may just have been the launcher).

Nothing seems to work


([ al]Bundy Racing) #4

I’m having the same issue. I’m a heavy Zwift user and this is the first this has happened. I tried unplugging/replugging ANT, rebooting laptop, and restarting Zwift. Power Meter and HR signals are being picked up by garmin head unit.

But Zwift picks up nothing. 


(Jon Mayfield) #5

It’s odd because we’ve not changed any of that code in a few months, but I’ll look at this today and see if we can reproduce it here.  I can tell you we have not had mass reports of power meter issues and we’ve had the same usage as usual on power meters since the update.   Just for clarification, are both of you guys using a USB extension cable to get the dongle closer to the devices?


(Joachim Sjogren [Sz]) #6

No extension. But laptop is within 1m if not closer, and have not ever needed to use one. It has worked flawless up until now. Previous years has worked perfectly aswell.

Screen from TrainerRoad right now.


(Joachim Sjogren [Sz]) #7

Is it possible to unistall, and remove all, and reinstall?


([ al]Bundy Racing) #8

I’ve been using an USB extension w/ ANT since I began.  The location of the USB has not changed. I’ve exhausted troubleshooting on my end. That’s why I need some assistance. 

 

The only other thing that has changed since my last use,  besides the update,  was during last ride my free trial expired and the Strava Premium 2 months kicked in. This would have been my first time signing in with that updated account status. 

Also,  FYI,  I use Garmin Vector and Garmin HRM. 


(Alistair Aitken) #9

Don’t know if this helps but I had a similar issue with cadence and speed sensors after the latest update. No pairing was possible until I unplugged ant+ dongle and put it back it, quit the program, shutdown & rebooted, then loaded all up again and searched for the sensors. Then it worked.

First time I’ve had to do that.


([ al]Bundy Racing) #10

I tried all that to no avail… 


(Maurizio Gigliotti) #11

You can try delete file knowndevices.xml
Documents directory/Zwift/knowndevices.xml


([ al]Bundy Racing) #12

So this is in the Windows Device manager?

Will the ANT+ devices then need to reinstall their drivers?


(Eric C. (Zwift HQ)) #13

That XML file just tells Zwift what you have paired before.

Please send in a support ticket and include your latest log.txt file and we can also look there.


(Joachim Sjogren [Sz]) #14

Found this site http://guides.macrumors.com/Uninstalling_Applications_in_Mac_OS_X

Removed all files related to zwift, and reinstalled. Now it works again.


([ al]Bundy Racing) #15

So I’ll uninstall and reinstall zwift-- I’ll give that a try tonight.


([ al]Bundy Racing) #16

ok. so i just tried uninstalling/reinstalling zwift and Zwift is still searching for my ANT devices which my garmin head unit is picking up.

Zwift tech Please advise. This is going to be ore frustrating, as i’m just beginning my indoor training routine. Since my strava premium kicked in, Zwift has been unable to receive my ANT signals . This doesn’t bode well for my paid subscription-- I may have to go with a Zwift competitor if this issue cannot be resolved fairly soon. I really want Zwift to work like it has for me in the previous 5 months.


(Jason K) #17

Thanks for submitting tickets! I’m looking at them now. :slight_smile:

If anyone else has this issue, please submit a ticket via bit.ly/zwiftsupport.


(Greg Caldwell MoveDaddy) #18

Was this issue ever resolved?  I used Zwift last winter and cannot get it to pair with my ANT+ now.   Windows says my ANT dongle is working properly.    I am running windows 10 with at Garmin ANT+ 2.0 with a Power2Max meter.


(Jason K) #19

@Greg: there’s no issue we’re aware of related to Power2Max right now, so the issue is likely specific to your setup. Make sure you’re going through the correct steps to pair your power meter, and if that doesn’t work, try changing your PM battery as well. It’s possible for it to show up in other software/devices, but still be too weak for Zwift.

If you’re still having issues after that, you can contact us at bit.ly/zwiftsupport.

This thread will now be closed.