4iiii on ANT+

Hi all, first post - hoping for advice!

I’m new to Zwift and had been running Garmin Speed/Cadence sensor no problems on my Macbook air with an Ant+ dongle and cable.

I’ve just bought a 4iiii power meter and Zwift can only recognise it via bluetooth (sometimes unreliably) and not the Ant+.

I have the 4iiii working with my garmin headunit via ant+ - but can’t get it going on zwift on ant+.

Anyone know what might be causing the issue and does it matter? I understand ant+ is more reliable and accurate?

Many thanks in advance!

I have a 4iiii left-side power meter and have never had an issue with it connecting to Zwift using ANT+.

All I do is start pedaling and it shows up on the Zwift Pairing Screen and I am good to go.

You could try a new battery and making sure that the ANT+ dongle is close to the power meter.

1 Like

Thanks Paul - OK good to know it can work!

Not sure battery is an issue as it’s brand new and reading 99% - the dongle was close to it and the cadence sensor (which is picks up no problem)…

I’ll try again though and double check everything. Cheers

Zwift will remember what sensors are paired from the last ride you took, did you clear out the selection, unpair the old sensors and search for the new PM?

1 Like

Is that the same battery that came with it? If so I would suggest replacing it.The app can read it at 99% but that may be incorrect (personal experience).

Thanks Mike, yes I did try that if I recall correctly, but will try again - (you’ve actually given me in the idea of trying it with my macbook’s bluetooth off, so it only has the choice of ant+ via the dongle)

Really, OK i’ll do that. Stands to reason the power meter could have been sat in a warehouse for months!

Hi Alex,

This is a good idea. I always ensure bluetooth is off whilst my ant+ items connect. Once they have hooked up I then put bluetooth back on.
So far so good.

Thanks Troy - i’ve tried a combination of all the above suggestions and got it working.

It’s not entirely glitch free (I’ve found zwift can be a bit temperamental generally sometimes) but a combination of pairing/unpairing, bluetooth on and off and pressing the ANT+ icon repeatedly on the zwift pairing menu page worked!

Thanks everyone for your replies, much appreciated.

1 Like