March 2021 Update issues

It’s not exact, but close enough to keep Zwifting…:+1:

Same issue here, massive power and speed increase today after update. my set up below ,
Window 10
Tacx blue matic
cadence/speed sensor Polar
no power meter
connect via built in bluetooth

i’ll try the fix suggested in the feed tomorrow with hope it will work

Same issue, power off the chart, cadence appears to be ok.

  • Windows 10
  • Tacx Blue Matic
  • Tacx speed & cadence sensor
  • Bluetooth via the companion android app

Tried the Elite nova force as others suggested but for me this is this is overestimating power compared with my usual Blue Matic settting.

Is there a way to delete the badges which I’ve undeservedly been awarded?

Hope for a fix soon :crossed_fingers:

It does give you the possibility to get a slightly higher w/kg, but doesn’t seem to affect speed much, so distance over time is not far out…that’s what I found on 2 X 15 mile trips…:+1:

Swap tacx trainer to elite nova force, should work…

For anyone using a Tacx Boost, Tacx Booster, Tacx Blue Matic, or Tacx Blue Motion:

I dug into the defined power curves and found what seems to be fairly close matches:

  • Choose Jetblack M5 Mag Pro instead of Tacx Boost
  • Choose Tacx Blue Twist instead of Tacx Booster
  • Choose Jetblack M5 Mag Pro instead of Tacx Blue Matic
  • Choose Minoura MagRide-60 instead Tacx Blue Motion

Edit: This is explained in a bit more detail in an article at ZwiftHacks.

28 Likes

Cool, will try that. Elite nova force seemed an ok option, but I will try the jet-black as you suggest, as you clearly have a more technical solution than my trial and error find ! :+1:

3 Likes

Fantastic work!

1 Like

Hapenned after latest u[grade or around that time. Same issue with Tacx Blue Matic, wahoo sensors, Garmin ant+, blew away my FTP yesterday. Had to slow ride for rest of ride. Hope they fix this.

Same issue.

Windows 10
Tacx Blue Matic
Garmin Speed & Cadence Sensors 2
Bluetooth connected directly to computer (not via Companion app)

Same here, using a Tack Blue Motion with Garmin Speed Sensor.

I have the same problem here:

Windows 10
Tacx Booster
Garmin speed sensor
no power meter
ANT+

Thanks in advance

good day. I have a problem with zwift. two days ago it was salty and not Yesterday.

I have an elite realaxiom 2015, connected to the application via cables./ I have a cadence, a control unit connected via cables to the trainer/I use NTB. a Yesterday 18.3 I can’t pair (find) a simulator with an application on any ntb all day. Why?

I tried to connect the trainer to 2 ntb, two different operating systems. and it doesn’t work. i use windows. I have been using the trainer for several years.

Still not fixed since Wednesday morning, same problem again…

Mac os
Tacx Blue Matic
Garmin Speed & Cadence Sensors 2
Bluetooth connected directly to computer, not using Companion app

Really frustrating as tried some of the other fixes likes picking a different setup and still didn’t work. I’m either ridiculously fast or dead slow 🥲

I am on the same set up Booster with Cadence and Speed sensors and HRM from being able to race at 4.2w/Kg I can now put out 650W at a HRM of 105 in a 21t cog some 9w/Kg. Makes the game completely unusable.

Try a different trainer as suggested by Jesper…

3 Likes

another trainer? Thank you for the advice, but I really won’t buy new ones.

my elite Realaxiom is smart (and the connection is via usb cables) and I have been using it for several years. I can’t borrow another trainer from someone else

Hi.
I’m using Windows 10pro
Trax Santori dumb trainer
Garmin speed sensor
Garmin cadence meter
Garmin heart meter
Ant+
Companion App on android

Neil Chesham.

thanks, I will give it a go later.

Thanks Jesper,

Jetblack M5 Mag Pro instead of Tacx Blue Matic

This worked well, very similar readings.

:slight_smile:

1 Like