March 2021 Update issues

Updated today, and now when I’m in a game, for 80bpm I am doing 38mph at 10w/kg. Before the update it was more like 28mph and 4w/kg. Obviously, this is now incorrect. However, in the sensor pairing screen, the numbers are right. This leads me to believe that the error is in the game, not the sensor pairing and setting. Been working fine for ages, right up until update today.
Anyone else had any similar issues? I have quite a basic setup, old Tacx (orange) simple trainer set as Booster (settings2), a heart rate monitor, Wahoo cadence, Wahoo speed, all on bluetooth back to a pc. No need for me to use the companion app. No changes in any settings, hardware and software all the same, only the update is a difference. This means I can no longer use Zwift, as due to the high numbers, it won’t record any of my activities, which is not my fault. I can only hope this is a glitch they will put right soon.

Quite a few people have been reporting this in the game update thread.

Hi Steve, do you know if there is a fix, or do I just have to put up with it until Zwift sort it out? Doesn’t appear to be anything I’ve done, only the update has changed. Really annoying, as all my challenges are now being made harder, as I can’t register any activity.

Yes, I have a similar issue. I’ve been using the 4-week FTP booster and after the most recent update my power is waaaay too high. I can’t stick to the power/cadence settings no matter how easy a gear I use. I’m on the same Booster (setting 2) with ant+ and speed+cadence sensors.


Someone has just suggested they may have changed the power curve for these trainers. If that is the case, I am not sure what to do. I guess I won’t be able to use it anymore, which is a shame. I need a quick fix for this really, can’t use it while it’s like this…Grrrrr.

Judging from the forum reports, this seems to be a problem introduced in the new 1.11.0 release. So unfortunately we just need to wait for Zwift to fix it.

You could always try raising it with Zwift support to see it there is any more information they need to help track it down.

1 Like

Yep, sent them a very detailed email with photo’s, just hope they respond quickly. Lots of people reporting the same issues with these trainers, so I guess they have changed the power curves of them. Very sad.


Gang - thanks for flagging this up We’re investigating this report.

If you are also experiencing this issue, we want to hear from you. It’s helpful for us to know what your setup is:

  • Which computer OS are you using?
  • What trainer?
  • Is there a standalone speed sensor involved in your setup, and if so, which brand / model?
  • Is there a standalone power meter? Which one?
  • Are you using Bluetooth, or ANT+ signal to pair those signals?
  • Are you using the Companion to pair your signal, or the computer’s built-in Bluetooth capability?


Experiencing this issue, and this is very annoying at the end of a training plan.

OS: MacOS 11.2.1
Trainer: Tacx Satori, but using Tacx Blue Matic
Speed Sensor: Garmin Speed Sensor 2
Cadence Sensor: Garmin Cadence 2 (Number seems to be ok)
No power meeter
Tried Bluetooth on companion and it was worse. Also, companion drained my phone battery.



Also similar to topic [16th March Update shows doubled power with speed sensor 2] in Bugs and support.

Hi @shooj,

I have the same issue. Here is my setup:
Windows 10
Tacx Booster
Garmin speed sensor
no power meter
Not applicable

Any suggestion for managing it whilst Zwift roll out a fix?


OS: MacOS 11.3
Trainer: Tacx Satori, but using Tacx Motion Setting
Speed Sensor: Magene S3+
Cadence Sensor: Magene S3+
Bluetooth to Mac
Tested both on Garmin Fenix 6 data appears normal. All worked fine up until the update, now rendering Zwift unusable.

Hopefully you guys can provide a fix, soon . :sob:


1 Like

Same problem.
Windows 10, Tacx BlueMatic with wahoo speed and cadence sensors over bluetooth connected to computer.

I’m having the same, barely spinning the wheels and got upt 800w

I have a Tacx Bluematic dumb trainer with speed & cadence sensor

Zwift is run from my iPad via standard Bluetooth

Please please fix this

The problem seems to be that the power curves for four Tacx trainers (Boost, Booster, Blue Matic, and Blue Motion) were changed in this update (at least in the Windows build). It’s easy to spot what was changed in the power curve definition file…


The chat issue.

Ever since the updates for performance issues that were found during Tour de Zwift.

I ride in regular events, like AHDR Bacon Rolls, that have 150+ people. We ride for 60 mins and we all chat and talk no sense but it builds a community with the regulars. We also keep an eye out for people who drop off the back. This was working well.

Then the update so chat messages are restricted to only those near you has ruined the experience and prevented us from seeing the chat messages.

Now we only see some messages, we feel disconnected from the group. We don’t know when people need help. We miss half chats. It has ruined the social experience which is what Zwift is about.

I know this change was for performance but this should not have impacted an event that is regular daily event.

If you are not sure, just ask anyone on the AHDR rides or people on these daily rides that are social and have over 150 people on them.


On mac build too…

1 Like

Windows on Laptop
Tacx Booster
Wahoo Blue sc
Built in Bluetooth to Laptop.

Android phone (v10)
Tacx T2650 (not smart)
Bontrager combo sensor (cadence and speed)
Companion: yes

Same issue here. Tacx boost with speed sensor. Zwift on windows 10.

Last night’s ride was a write off. Power swinging wildly from 30w to 380w with the same low effort. Gave up on the group ride as I was doing 58 km/h without even breaking a sweat