Mac beta hard graphics freeze when starting rides


(Ryan Meader) #1

Every time I try to start a ride, my entire system freezes (mouse pointer still moves, and game background audio plays, but the entire screen and system UI becomes permanently unresponsive). I have tried deleting and reinstalling the app, fiddling with almost everything in the config files, restoring them all to defaults, rinse and repeat…behavior is unchanged. I would submit a system crash reporter output, but because the system freezes every time and I have to reboot, I don’t have any. Just the Zwift application logs.

I’m on a first-generation quad Core i7 27in iMac with 8GB of RAM and a 512MB ATI 4850 GPU. Granted, it’s fairly old, but I can’t think of any reason why it wouldn’t be up to the task and I see people with similar hardware playing the Mac beta successfully.

I’ll submit the application log to support@zwift.com, but figured I might see if anyone else is having similar issues and if we can narrow down the potential causes at all.


(Jason K) #2

Moving to Troubleshooting forum. Sorry for the belated response - we’ve got a very high support load right now, but I’ll try and respond to your ticket today. Thanks for your patience!


(Ryan Meader) #3

Thanks for the reply, Jason. I figured as much since the Mac beta has only been out for a short time…I’m certainly eager to start using Zwift, but I can be patient.


(David Hewes) #4

Have you tried repairing permissions? I am running an early 2006 Mac Pro 1,1 and it is awesome. Dem dare Macs is awwwwsome.


(Chris Quigs [MG]) #5

I also have this issue on my i5 iMac 27. Radeon HD 4850 as well, 512MB. I can log in, but once the music cues up I get a hard lock and have to hard reset my machine.

I have two other Macs (a new Air, and a 2012 Pro) and the beta works fine on both of them - it’s just the iMac that doesn’t agree with it. It’s interesting that Ryan and I have the same problem with the same graphics card.


(Ryan Meader) #6

Yeah, I was fairly confident that this is a 4850-specific (or at least specific to its closely related family of ATi GPUs from that generation) issue. I don’t think it’s unfixable. My suspicion is that there is some software feature (FXAA?) that breaks on the ATi 4850. I continue to try tweaking the variables in the settings files, but ideally in the next update Zwift would detect the affected GPU families, and disable that feature. I’ve helped other game developers work around similar issues in the past, so I’m confident that it can be done.


(Wayne Jordan) #7

Same gen iMac as Ryan, same problem.  Freezes the whole system requiring a hard reboot.

Ryan, did you ever find a workaround?


(C B) #8

same system, same graphics card, same issue.


(Scott Armour) #9

Exactly the same issues with same graphics card as above. Tried on Macbook and no issues. After a quick browse I hope you get a fix for this as when it works it was brilliant, will transform turbo sessions


(Fritz Cardozo) #10

Exactly the same hardware as me and exactly the same results.  It just freezes the whole computer.  Interestingly if you try and run the game with the ANT+ dongle unplugged it doesn’t freeze the whole computer but just the Zwift app.

Please provide a fix for this guys!

 


(Tom Nackaerts) #11

Same hardware, same problem…


(George Asgari) #12

I just downloaded Zwift on my iMac (iMac mid-2011 27" 2.8 i7 16gb OSX 10.10.7) exact same crash on splash screen.

Zwift ran perfectly on similarly spec. MacBook Pro Retina. No issues.


(Jason K) #13

This is a really old thread, so I’m going to give it some closure. :wink:

As mentioned in our minimum system requirements, Zwift requires a GPU with 1GB of memory while the 4850 is six years old and only has 512MB.

In general, Zwift will run on most computers that were built in the last three years. If you have a computer with a different graphics card that seems like it should meet those requirements but won’t run, submit a support ticket via http://bit.ly/zwiftsupport.

Thanks!