MAC and USB2 Dongle: "No ANT+ Dongle"


After months waiting for a invite I got one and was eager to try zwift. Now I’m getting the “No ANT+ Dongle” message, but I do have the ANT+ Stick (old one, long and rounded, and sure it’s USB2!). I have a Mac Mini i5 2.3ghz hooked to LCD TV and zwift cant find the ANT+ Dongle. On the same Mac I’m used to use trainnerroad, and the stick works flawless with a Heart Rate Strap and a Powertap Elite.

Since I was running OSX 10.9 I thought that a upgrade would help, but going to 10.10.2 didnt helped. I also tried to install garmim express in the hope that it would install a driver or library needed by zwift, but also without luck. I had read the docs and know that I have to close the garmim app because it could grab the USB device, which I did.

Today I tried the zwift and the dongle on my desktop mac mini (same hardware: i5, 2.3ghz, OSX 10.10.2) and it worked!! Now i’m puzzled on why it works on my desktop machine, but dont on my other Mac. It’s not a USB port problem as trainneroad can find and use it. What else is needed to make zwift run? Please help :-).

are sure that the other Mac port is usb 2.0? Some have reported the distance from computer to device is long (needed extension).


Hi, the problem is a little trickier and I’m glad that I solved it. Believe it or not, but the problem is that my non-work mac has a case-sensitive file system, so probably zwift was looking for something like “iosusbfamily” and the file was “IOUSBFamily”. After a lot of backup/re-install/restore time my mac now has a case-insensitve file system and zwift is working!

Wow, thx for the hint that the “case-sensitive” file system is the problem. 

Had exactly the same issues. I created a new partition on the hard drive and installed a separate osx, this time as case-insensitive, and now everything works fine.

I also had the same problem on my mac notebook. But there is a simple solution: create a virtual volume, mount it, and symlink the ~/Library/Application Support/Zwift to it.

Hi Christian,

I am dealing with the same problem. Could you explain a bit more detailed how you did it?



Hi Sven,


I had to reinstall OS X on my notebook and lost a few things (the custom zwift…). So I’m writing from my poor memory :-).  

  • run disk utility app, choose file->new image. Choose the file name, the name of the volume, the size (can’t remember the original size… i would try 500mb or 1Gb to be on the safe side). And most important: format as OS X extended but NOT case-sensitive :slight_smile:

  • open finder, find the fie image you created and click on it to “mount” it.

  • open a terminal app and mv the files from ~/Library/Application Support/Zwift to the mounted volume. Something like:

mv ~/Library/Application Support/Zwift/* /Volumes/zwift_volume

  • the final step is to symlink the old directory to the new one (also remove the old dir):

rmdir ~/Library/Application Support/Zwift 

ln -s ~/Library/Application Support/Zwift /Volumes/zwift_volume


if you use to shutdown your mac instead of put it to sleep/hibernate you will have to mount the zwift volume everytime you boot it. I used to create the image file on my desktop and just click on it before launching zwift. 


hope this helps!

Is this really what it takes to get Zwift up and running on my new Mac laptop? If that is the case I’ll have to pass on Zwift.

Hi Fred Flores,

No, it’s not. This is needed only if you have a case sensitive file system, which is not the OSX default. You should be ok with your new mac laptop.


i’ve come across the same issue. Zwift works on one Mac but not on the other. However in my case both file system are non-case sensitive. Does anyone know if there is an issue with usb-c as the Mac where it does not work is a Macbook 12’’ with only a usb-c port.

Thanks Marco

Hello all,

I also have a 12" MacBook with USB-C and adapter. My Mac doesn’t seem to find the Ant+… :-( 

Any ideas on how to solve this problem?