Login Issues Zwift Germany / Telekom as ISP - including workaround

Hi, maybe this is helpful for some people in Germany. I’ve just been on the bike for over an hour and saw all countries but surprisingly few German flags.

Updated: 14:15h CEST - to reflect feedback from Zwift support

Issue
Since yesterday around noon CET, no login possible to Zwift from iOS Companion App, Zwift iOS and Zwift macOS. ISP provider is Deutsche Telekom, fixed line, or Deutsche Telekom, mobile network.

Via mobile network, at least the Companion App started working very slowly. Extremely slowly.

Workaround
Bypass the DNS / WAN Routing of Deutsche Telekom. As there are multiple resellers of Deutsche Telekom services, your ISP may be affected (like 1&1 in Germany).

Using a VPN service provider can help. NordVPN works for me, I have no affiliation with them and there are other, free (or trial period) services available which will probably just do fine.

Solution
Get in touch with your ISP and ask them to get their WAN routing straight. Zwift support recommends patience until the ISPs have fixed their issue within days, but I’m not aware of them driving this actively.

Explanation
After some exchange with the (fast!) Zwift support, we came to the conclusion it may be an ISP problem (which I did not buy, at first). Seems like it’s true, if you connect via VPN, issue is gone. For me, any country worked, direct to USA west coast, Switzerland, even Germany. A traceroute to zwift.com and secure.zwift.com shows dropped packets, when run without VPN.

Catch 22
If you’re able to read this post, you’ve probably found a way around the login issue already as the forum uses the same server address and thereby routing.

Thanks for your post. I can see the forum but still can’t log in to Zwift.

I have the same problems - my provider is 1&1. Is there any solution in sight?

Same issue here in Germany/Munich/Telekom ISP - looking at traceroute, I assume there is an issue with Deutsche Telekom’s WAN routers; seeing many timeouts after d-ed5-i.D.DE.NET.DTAG.DE. I have been unable to log in to Zwift since 6 PM CEST yesterday.

I’ve just switched my Zwift machine to a VPN service provider and routing via Switzerland works like a charm and lightning-fast.

BR, Thilo

Thx.
Will install my OpenVPN System on my Zwift-PC later.

and… the forums here work fine with Telekom/1&1 :wink:

edit: just tested it with a server in netherlands and yep, zwift works fine from there :slight_smile:

I can log in again now!

Everything working and back to normal :blush:

Had the same problem in Austria, Provider Drei.at.

Same here. Provider Telekom. Second Day today.

And here, Congstar WiFi which is just another brand of Telekom. Can’t login or use Zwift.

10:30am and problem is back. Zwift companion hangs.

Same Problem in northern Germany! Third evening this week, i am totally annoyed of this problem. I have no time to Ride My bike outside…therefore i need a working app for indoor training…but it ist still impossible to login at start. Damn!
PLZ Zwift, i Need help!

If you need just any app to ride indoors, try RGT Cycling or Rouvy until this problem is solved.
If you want Zwift, try Hotspot Shield. It’s a free VPN Service.

Ben, trank you very much for your help! VPN works and i can start zwifting again, god bless you!:-))

1 Like

I have the exact same problem with my Telekom ISP. Using VPN or Hotspot from my Mobile via 4G (Vodafone) works. This is crazy!

Telekom seems to be aware of the problem and is working on it.
See Links from @Steffen_Fischer_ZRG