L'Etape du Tour Stage 3 - fail

Start up Zwift and mini-map doesnt show on Companion App. Old problem for a few of us that continues to not get fixed.

Start ride sitting in the pen (managed to be about 290th on), race/ride starts and all looking good except me and another avatar turn left out of the pen and head into town instead of right to go up the hill…grrrr. Can see everyone go the other way in the main screen mini-map, just me and my new mate now going for a beer by the looks.

Restart, only 1km down or thereabouts and getting back into the rhythm and then leader-board starts disappearing. Can still chat, see chat, etc, but no idea my placing.

A lot of people seem to have problem with these big events, and I appreciate that a lot more dont, but geez, this is a difficult platform to recommend these days.


I was having this issue too (Companion app wouldn’t “see” the game app even though they’re on the same WiFi signal). I’m running the Android version.

I tried the usual things

  1. Made sure my Android running Companion and the laptop running the game app were on the same WiFi SSID. < This didn’t help this time

2a) Purged the Copmanion app’s cache. In Android Settings > General > Apps & notifications > App info > Companion > Storage > Clear Cache.
2b) In the same place as 2) I also Cleared Data. < These two steps are like resetting the app without completely uninstalling / reinstalling. < Step 2a and 2b didn’t work this time either

  1. Uninstalled & reinstalled Companion. < This worked like a charm.

The following steps that I’d pursue after that are:
4) I have a bunch of apps installed that I don’t really use, so I’d uninstall the deadwood to clear storage and RAM
5) It’s been probably a solid 18 months since I wiped the Android (aka hard reset). Even though it’s a pain to reinstall apps, it’s a bigger pain when my phone runs slow, or apps glitch, so I hard reset it every 12 - 18 months. Old habits from the early days of Android die hard, what can I tell you?

Thanks @shooj but you dont seem to recall the thread that you participated in where a few of us have the same problem and have already told you what we have tried. You folks have already said its a bug so no need to start troubleshooting 101 again.

Simply put, phone is factory reset, dedicated to Zwift, PC is on Gb wired connection to ISP and only has Win10 and Zwift loaded and phone has no problem seeing when PC is running Zwift. The phone runs no other apps.

I’m having a rant because the problems I had tonight are recurring with me, or others, frequently and I’m getting frustrated that you folks continue to ignore the niggles the minority of us have. Tonight I hit a few of your bugs at the same time which is a first and while I continue to see you folks put effort into e-racing and new maps, I simply want things that used to work, to continue to work, I shouldnt have to wait 2 years to get a bug fixed (and yes, you folks have already told me that my map problem is a bug thats in the queue to get fixed - over 12 months ago).


Come on Shooj. Asking people to do a hard reset of their phone for a 2 year old Zwift fault is a bit much. You are always very helpful and your efforts are much appreciated, but we’d prefer some honesty - we haven’t fixed it yet sorry - rather than unrealistic workarounds to avoid taking responsibility.