Lag issues with other riders

Hi everyone,

I am having some problems with Zwift over the last few days, was hoping anyone is able to help me solve this.

I can start rides, trainings etc., without any issues. Also pace-partner rides with lots of fellow zwifters. Everything is running smooth, no problems so far.
After a few minutes into my ride though, the other riders start to lag, bouncing on and off the road, changing direction etc. My own avatar is maintaining a steady line. The connection is never lost, I can continue my ride, hence only with other people ping-ponging around the road.
This problem allways occurs after a few minutes, on pace-partner rides, own training rides, etc. Also when just following others, and not riding myself.

In short:

  • Setup: Zwift on desktop, Windows 10 64-bit, I7-3770, ATI RX 570, 16 GB RAM, SSD 120 GB
  • Drivers / OS up to date
  • Zwift installed to SSD
  • Connection wifi: 60 MBps dowload, 80 MBps upload, ping 3 ms
  • Important: this issue does not occur when running zwift on my laptop, or Ipad!
  • I have also checked the connection by running online games via steam: no issues…

Things I have tried:

  • Reset router / wifi several times
  • Reinstall GPU drivers
  • Make Zwift priority via processhacker
  • Reinstall Zwift

Since I have run out of things to try, I am realy hoping anyone is familiair with this issue and is able to help me out!

Thanks in advance,

Kind regards,


It’s some sort of connection issue with Zwift’s servers. You seem to have already tried all the basics. But it seems to be to do with your PC, so I suspect a comms issue on your PC - e.g. network drivers or the network adapter itself. Check the drivers for your network adapter. Also consider trying a different network adapter, e.g. it wouldn’t cost much to buy a different network card to try - is this wifi or hardwired?

Actually, one thing you don’t seem to have tried is reinstalling Windows. Admittedly it’s clutching at straws, but you never know …

Thanks for your reply Steve. I have also tested using a cable in stead of the wifi-adapter (PCI-E). This was no succes.

However I have just ran Windows 10 update 21H2; turns out OS was not up to date after all.
This seems to have fixed the issue! Not sure why the issue started now, but I’m glad its fixed!

1 Like