Network Problem

my wife and me are using zwift since 6 weeks.

we have 2 identical elite smart trainers, each is connected separately via ant+ to a note book.

my wife uses an old notebook, everything works stable and perfect. we use the same WLAN router.

but i have since begin massive problems because of freezing during a ride. connecting sensors per FE-C works perfect, but after 10-30 the sreen is freezing and it is impossible to continue. i made a attempt using a LAN cable connection but the problem is the same.

i read all the good ideas and bug fixes, disabled firewall, disabled bt, zwift app new installed, windows 10 new installed. but nothing helps. it doesn´t matter if i ride allone or if my wife is also riding on here trainer.

zwiftalizer shows problems on NETWORK CONNECTION (reconnections).

reading the log file showns always the same problem after 10-30 minutes:

[8:36:43] NETCLIENT:[WARN] UDP connection timeout (1 so far), reconnection attempt 1

this will repeat 5 times (till 5 so far, reconnection attempt 5) then everything stops.

I have done everything i could and i`m now at the end of the line.

please help me

thank you

Roger

I’ve got the same problem since the beginning of January. It doesn’t always happen and it doesn’t follow a specific pattern so that I could narrow down the issue.

I play on my desktop PC with a wired connection (over a powerline adapter) and already tried to reinstall Zwift. I even bought a new router, but the problem persists. I will try to run a cable directly into my router maybe…

If anyone has any other ideas or suggestions I would be glad to try them as there is nothing as frustrating as a crash in the middle of a race.

I would need a lot more info to better assist you.

1 Like

Can you tell me what kind of info would you need? Like PC configuration, game settings or maybe networking info?

I think i noticed a trend, but I wouldn’t put my money on this though. I usually leave my PC on sleep all the time and I think I never experienced a crash when I started Zwift right after a PC restart. Maybe there are some background processes or maybe Zwift doesn’t do a graceful exit and that would lead to later crashes(?). That’s a really wild guess, but I don’t really have anything else in mind that could cause them.

You really have not described your issue in detail yet.

Also hardware info would be helpful, how you connect your sensors (ANT+ or BLE).

The more info about your entire setup the better, but right now I cannot even make a guess with the limited info.

1 Like

I assumed it would be redundant to reiterate what Roger wrote in the first post but here it goes:
Sometimes when I am in a ride (solo, workout, group, race - doesn’t matter) after a random amount of time (be it 5, 10, 20 or more minutes) the game freezes and crashes (exits). The game logs look like Roger’s: NETCLIENT:[WARN] UDP connection timeout (12 so far), reconnection attempt 12 - the game crashes after a random attempt number also but it seems that it still tries to reconnect after the game is closed (or maybe there is a delay in writing the log files). Internet connection is up all the time and most of the other programs are closed.

The setup:
GeForce 1060 6Gb, Ryzen 5 2400G, 8 Gb Ram (tried lower graphics settings to be sure there’s no bottleneck somewhere)
Windows 10
All sensors and trainer connect to PC through BLE
Trainer: Wahoo Kickr Core
Wired Internet Connection through Powerline Adapter
Internet Connection has always been stable

Capture2

Zwift only needs internet connection for the initial start to your ride and near the end to make sure it uploads to the Zwift servers and 3rd party sites. I sometime disconnect from the internet (disable network adapter) and ride on the roads all by myself. You could try this to see if Zwift still crashes.

I have never been a fan of Powerline network adapters, if possible I would run either a CAT5e or Cat6 from your router to the Zwift computer. You could have some faulty wiring somewhere that is causing Zwift to receive many errors and crash.

Ping and Jitter only tell you so much, you would need some kind of network tester and that might not tell you the entire story because there could be lots of junctions in your wiring that cause issues (or just low quality wire).

There could also be issue with your route or modem so I would make sure that the firmware is up-to-date and it would hurt to restart them both periodically. Also make your you computer OS and ALL drivers especially your NIC is up dated.

Now for outside your control, there could be some strange issue on your incoming line that your ISP would need to diagnose to see if there are issues.

2 Likes

Thanks for the tips. Router has been changed and the new one is up to date so I can cross that off. I was going to test a straight cable from router to PC these days, but I reckon the debugging will take a while since the issue does not manifest regularly - I went through a week without problems and in the next 3 days there were 3 crashes. I’ll be back with a feedback if I get to the root of this. Thanks again!

1 Like

Hi

I am also having the same issue, the connection attemps dont dreeze but never sucessfully reconect.
I have done the following:
reinstalled windows
reinstalled zwift
updated drivers
ran zwift with nothing connected just watching riders
used a cat5e cable to route out wireless
ran a constant ping to google with 99.9% ping sucess rate
firewall disabled both on pc and router

my enviroment
50mb fibre connection
hp i5 notebook 8gb ram with ssd intel graphics card
bluetooth 4.0 dongle
zwift runs on windowd mode on medium graphic settings
wahoo core (non relevant as it still hapens when just running zwift with no devices added)