Lack of write access error [March 2024] [Launcher 1.1.12]

Hello,

I just finished my first race in quite some time eventId=3580324.
The race shows up in my ZwiftPower profile but that’s the only place I can find it. It is missing from the Zwift Feed and my linked Strava account.
In Documents\Zwift\Activities the newest file, the “inProgressActivity.fit”, is from two weeks ago. After restarting the game, a few sentry files were created in the Zwift folder which makes me think that something didn’t work as expected during the last session, though this is just speculation.

Is this a known Issue, because this is the first time I encountered a fit file missing completely.

Edit: I just saw that Windows “controlled folder access” blocked ZwiftApp.exe, as well as ZwiftWindowsCrashHandler.exe from accessing Documents\Zwift\ at the time of the race. This might just be a coincident but could be causing this issue

After updating to 1.61.0 today I received an error about lack of write access for ZwiftApp.exe’ (Windows 11). After closing Zwift and restarting, the error message did not reappear, so I (mistakenly) thought it was all good as the login screen says Version 1.61.0.

However, my Big Spin Stage 2 Long ride from today was NOT recorded, even though the Save screen appeared to work normally. No .fit file, no updates to any .xml files in …/Documents/Zwift, no updates to Big Spin status or the March mission elevation. A couple of things were, however, odd during and after the ride - I did not receive any Ride Ons nor were any images available to upload during Save.

My previous ride on 3/17 recorded properly. Looking in the Program directory, I see the Zwift_ver_cur.xml says 1.61.0, and the ZwiftApp.exe is dated 3/16/2024.

Has anyone else had a problem with the upgrade in this manner.

Update: Fixed by adding ZwiftApp.exe, ZwiftLauncher.exe and ZwiftWindowsCrashHandler.exe to the Allowed Apps in Controlled Folder Access. Better yet maybe just to disable Controlled Folder Access. Even I cleared my Cache and Cookies in Chrome, I can’t see how that would impact access.

1 Like

Exactly the same here, exactly as you described (but on Windows 10). Took a few days until I realized what went wrong. Went into the system settings to the Windows Defender Firewall settings and gave “zwiftapp” the permission to communicate over the firewall. Problem solved.

Edit: Not solved entirely. Now I was able to give ride-ons, the ride was saved in my activities, but the manual screenshots were not saved and there is no log file (only a launcher log file).

You might want to test with the firewall completely turned off to see if you need to work on the permissions more.

Turns out that ‘somehow’ between Zwift updates, Windows Defender Controlled Folder Access was enabled. I added Zwift to the allowed apps and re-ran ZwiftSetup, this time without any file access error. I am considering disabling CFA or running it in ‘audit’ mode as suggested by some.

1 Like

@John_Mathes and @Kerstin_K_C2rower

Thanks both for flagging this up. We’re investigating.

I’ve only just updated to 1.61 today and did 2 rides (last rides were Mar 19 before I had the latest updates) and now I have similar issues - there are no records of my activities in the companion app, no recorded FIT files in documents/zwift/activities, no record of completing Stage 3 Big Spin and activities weren’t uploaded to Strava automatically. I have however, seem to have retained a new prize which is the only thing that seems to show I have actually completed a big spin ride.

I didn’t see any apparent errors for write access although when checking the Controlled Folder Access and clicking on recently blocked items Zwiftapp was there so i’ve now added it to the allowed list. Haven’t tried another ride just yet to see if the save issue persists.

I’ve heard some people say that the Defender ransomware protection setting is causing problems

@John_Mathes and @Kerstin_K_C2rower , would either of you be able to add an exclusion for Zwift to your Windows Defender ransomware protection? This should help confirm whether the recent reports of issues with ransomware protection that @Paul_Southworth mentioned are the same issue you’re experiencing.

2 Likes

@Rowdy Adding an exclusion seems works for me now with workout files now being able to be saved in the activities folder.

2 Likes

I can’t add an exception. Is there a way to move Documents/Zwift folder? Is there a fix to be released soon?

Yes, I ended up adding ZwiftLauncher, ZwiftApo and Zwift WindowsCrashHandler .exe to the Allowed Apps in Windows Controlled Folder Access (Ransomware protection)

I road yesterday and all seems back to normal. Frankly, I’m tempted to disable CFA

John

1 Like

@Rowdy All seems fine now. I fiddled around with the settings, now it seems to work as usual, and I’m getting log files again. Turned out that the missing screenshots happened because I re-installed the Companion App and didn’t give it permission to access the iPhone folder.

However, I’m not really sure what caused the Zwift App to work again. I’m no Windows expert, and using the German version of Windows doesn’t help either when you follow the guides. But I know for sure that the bug started with the update to 1.61, never had that sort of trouble before.




After the last 2 training, Zwift no longer save it, and don’t upload to Strava. On my windows PC under document there is no files.

PLEASE help :blush:

There have been several reports that the Controlled Folder Access settings in Windows are affecting saving rides

https://forums.zwift.com/t/game-update-1-61-march-2024/626862/103?u=paul_southworth

2 Likes

Can Zwift support and send me the files, that normally is saved on
Documents\Zwift\Activities folder or can I find it myself?

Hi,

Is possible to send me some links, I’m not aware how to do - THANK you

Take note of the Allowed Apps names in the comment I linked above, and add them to your settings which you can find described in this document:

2 Likes

I don’t see Zwift files in Dropbox, should I re-install Zwift on PC….,a bit tired!

I doubt reinstalling will help with this issue. To test the issue you can try disabling Dropbox entirely, or disabling Controlled File Access entirely, do a ride after each change and see if it makes a difference. That would narrow down the scope of the problem.