Kilometre countdown has changed

I don’t know if this is a bug or a change but I hate it. In my last 3 Zwift cycling races when I thought the race was coming to an end because the blue distance bar is full and the KM countdown has gone down to almost zero. Then, the countdown is suddenly set in metres at a figure like 6399 for example. And then goes up and down over a further few KMs - at which point I am already spent. I could of course know there are a few miles to go if I know the course but that’s not the point.
What is going on?

This bug was definitely around a while back, but I thought it had been corrected since. Are you on the latest version of Zwift?

1 Like

Hi @_E_E welcome to Zwift forums!

As Nigel suggested, you’re running v.1.0.43784 of the game app. Updating the game app should fix you right up!

Also FWIW, your iPad is on iOS v12.3.1. While there are valid reasons to not auto-update iOS, Zwift recommends you update to the latest version that Apple offers for your iPad.

Would you loop back and let us know this solved your problem? Thanks!

Thanks guys! I updated my Ipad and my Zwift app and today it worked perfectly