KickR spindown process now doesnt work in Zwift?


(Craig Howard WBR B) #1

 This used to work flawlessly for months for me until Wahoo updated their firmware in Jan. Infact Zwift and Wahoo both updated on the same day for me but I guess it’s Wahoo that have goosed it?

I used to be able to warm up for 5 or so mins on Zwift before I enter a race or group ride. Once the KickR was warm I could activate bluetooth on my phone and while on “the virtual turbo” before the start line, I could perform a spin down, turn off the bluetooth and Wahoo app on my phone and all would be well.

Now it simply doesn’t work whatever the scenario while in Zwift. I’ve even got to stage where I unplug the ANT+ dongle mid-ride but then that made pairing all the sensors a pain again and Zwift needed a full restart.

 

There must be a way for Zwift/Wahoo to get spindowns to work within Zwift. Its a right pain to warm up solely via the Wahoo app, turn off bluetooth when done on your phone, get off the bike, boot up Zwift on the PC, log in, get back on bike and finally start riding again.

It used to be great and now it’s a right pain in the ass - especially for those 1 hour sessions…


(Jason Roth) #2

I’ve had exactly the same issue. 


(Craig Howard WBR B) #3

I raised a ticket with Wahoo and they said nothing is wrong because I shouldn’t be using any other device with the KickR. So basically, one device at a time and not multiple such as Zwift using it’s ANT+ signal and the Wahoo phone app using the Bluetooth Kickr signal.

 

:frowning:


(Jason Roth) #4

I agree, that’s quite disappointing. 

It used to work just fine - exactly as you’ve described - ride for 5-10 minutes to warm up the SNAP, then switch over to the Wahoo app to do a spindown. 

I know that I needed to exit the Wahoo app (i.e., force quit) to be sure there wasn’t interference with Zwift after, but otherwise it worked fine.

Since the January updates to Zwift / Wahoo it doesn’t work at all. I know I’m getting unusual/incorrect power figures in Zwift because I haven’t done a spindown - but have to exit Zwift to do a spindown. 

I am sure that Zwift has led to a big uptick in sales of Wahoo Kickr & or SNAP, you’d think that Wahoo would try to “play nice” with Zwift, and not refuse to admit it exists.


(Todd Nichoalds) #5

I’ve also had the same issue.  It was quite frustrating until I figured out what was happening, but I don’t find that I have to exit Zwift to perform a spindown. 

I start up Zwift and do my warm up as normal, with the SNAP paired to Zwift both for power and controllable trainer.  When I’m ready to spin down, I simply unpair the SNAP from the controllable trainer on Zwift, start up the Wahoo app and do the spindown. 

Once spindown is complete, I close the Wahoo app and re-pair the SNAP to the Zwift controllable trainer.

It’s not ideal as it requires a little more button pushing than before, but it works.  I guess it is a bigger deal if you can’t reach your PC from the bike, but I’m fortunate enough not to have that problem.

I’m more concerned with the fact that power when using ERG mode seems to be a lot more erratic since the Wahoo firmware update.  My power jumps all over, which it was not doing before.  I assume that’s on Wahoo’s side and submitted an email to their support team, but I don’t have a response yet.  (Sorry if this last part is too far off topic.)


(Craig Howard WBR B) #6

I’ll give that workaround a try. As you say - it’s a bit of a faff as I have to get off the bike and walk over to the PC and plug in a mouse etc.

I’d also want to be doing this spin down process within the 5 mins “waiting area” before organised races/training rides.

So the most simple way is…

Warm up in Zwift / auto stage 5 mins before / jump off bike / unpair KickR / Get on bike / load up Wahoo utility on phone and turn on bluetooth / perform spin down / close Wahoo app and turn off bluetooth / get off bike /  on PC re-pair KickR over ANT+ / Get back on bike and prepare to ride!

WOW! What a step backwards and the time margins are slim!

 

 

 


(Todd Nichoalds) #7

Absolutely agree with you 100%.  I’m guessing just about everyone impacted would prefer it to work the way it worked before the recent firmware update from Wahoo.  That said, I can see why Zwift doesn’t consider this an issue.  Since it was the Wahoo update that seems to have caused things to work differently, from Zwift’s perspective nothing has changed - and therefore working as expected.

Sounds like maybe you are using a desktop, but if you have a laptop or even a wireless mouse available, then I’d highly recommend some type of computer desk that will let you control things from the bike.  I’m able to go from unstructured riding to a workout and make other changes (such as pairing/unpairing from Zwift) on the fly.  I don’t even have to stop pedaling.

I overpaid and got the Wahoo workout desk because I had a gift card to burn, but I’ve seen equally good and much cheaper set ups.  The stand-up computer work desks seem to be a good solution.  Maybe not as good as spindown working the way it used to, but at least a solution you can implement yourself.  :slight_smile: