Kickr Snap not reporting power


(Jens Straten) #1

My Kickr Snap suddenly has stopped reporting power back to Zwift. I have already tried the Wahoo utility app to confirm that it still sending power data and it works fine with that. The Zwift application still finds the Kickr Snap and pairs with it, but then it never receives any power data. Also tried a different ANT dongle with the same result.

On my end, I can recall that the following three things have changed since it has worked successfully:

  • Zwift application update

  • Wahoo Kickr Snap firmware upgrade

  • Windows 10 x64 upgrade

Any ideas or suggestions? Thank you!


(Paul Graham) #2

Is your trainer paired with the FE-C component of the pairing screen Jens?


(Steven D) #3

Hi Jens,

Have you seen our Zwift KB article for Kickr Troubleshooting? If not, I would strongly advise you to review it and you may very well find the solution to the problem in that guide.

Here’s a few additional suggestions for things you possibly haven’t tried yet:

  1. You mentioned you tried a different ANT+ dongle, but have you tried using a different USB port on your computer? Most USB ports provide 500mA current but some only only provide 100mA. This is why trying a different USB port can improve your ANT+ signal.

  2. Change your WiFi router channel: If you have a 2.4 GHz WiFi router, use channels 1 to 5 and avoid channel 10 becuase it uses the same frequency as ANT+ (2457MHz). This is still an issue even if the computer you use for Zwift has a hard wired network connection because other devices nearby that use WiFi - your phone, or someone watching Netflix on a Roku next door - could be flooding the environment with noise.

  3. Stop and close any apps or software that may be connecting to your Kickr Snap. If there’s a trainer specific app (Wahoo App for example) or anything running that may be interfering with Zwift, let’s make sure those are closed out and that nothing is running in the background on your computer that would cause interference and try to read the dongle at the same time as Zwift.

If you’re still having problems after giving that a try, please submit a support ticket and one of our Zwift support team members will be happy to further troubleshoot this issue.


(Jens Straten) #4

Thank you for your replies!

@Paul Graham

I am not sure what the FE-C component is, but the pairing screen shows the trainer connected as a Power Source and Controllable Trainer.

@Steven

Yes, I actually looked the KB article before posting.

I also tried different USB ports (USB2 and USB3), but no change.

The computer is a desktop PC. So, no WiFi and our WiFi router is located in a different room.

I can get a power reading using the Wahoo App, but I am guessing that app is using bluetooth and not ANT+. Will try again moving tablets and mobile phone out of the way, but not much hope that will make a change because they have been at the same location when it worked previously.

If there aren’t any other suggestions, I will go ahead and open a support ticket.


(Paul Graham) #5

Hi Jens

At the pair screen you will have a couple of options.

‘Unpair’ the ‘Power Source’, which will then give you the option to search. Initiate a search and you should see two options available, the one you are possibly running currently and one with FE-C … within the description. Choose the FE-C.

Do the same for ‘Controllable Trainer’, unpair, search, choose FE-C.


(Jens Straten) #6

Sorry about the slow reply, but I got caught up in work. I can now confirm that Zwift automatically finds the FE-C Kickr Snap devices for power source and contrallable trainer.

Sadly, it still doesn’t report any power. So, I went back to the Wahoo Android app. While the app is using bluetooth, it does report speed, but not power.

So, I am guessing that something is wrong with my power sensor? But why would speed still work?

Maybe it is a firmware issue? I mean it worked fine before that.

Anyhow, I have opened a ticket with Wahoo. Hopefully, they can help me sorting this out.