kickr snap and zwift


(Ryan Pulver) #1

I have seen a few posts with people having issues using the SNAP with Zwift. I have unpaired everything, done both advanced spindowns and regular spindowns and nothing seems to help. The wattage figures in both the Wahoo app and Zwift are near identical but seem extremely low. In the highest gear pedaling at full power I can’t even reach 300 watts. In the lowest gear I can pedal as fast as I can and my Zwift avatar wont even move. I am on the latest firmware and used an iOS device. It is not in ERG mode, or at least the app says its not. Any ideas? Anyone been able to fix this problem? Am I just a weakling? Thanks!


(Karim Kanji) #2

Same thing here, full gas sprinting and I can only just about touch 300w. Maintaining 200w even for a couple of minutes is really really hard. This is the same in ERG or normal riding around mode and after I have completed both a standard and an advanced spin down . As a comparison, strava estimates I averaged 275w for 8 minutes on my local hill at the weekend and the guys I normally ride with have ftps measured between 250w and 300w on watt bikes, power meters etc


(Finlay red Stig | JRA Cyc) #3

I have the same issue with my Snap as well.  Just got it this week and have been on one ride. The harder I try to hammer the worse the reading, meaning that sprinting is out of the question. I haven’t tried yet, but I’m going to put the ANT+ dongle closer to the flywheel on my next ride. Hopefully it’s a signal issue. When I use the Wahoo app via BTLE there are no power dropouts.

I might also try this with Bkool to see if it’s a trainer vs. Zwift thing. But first the USB extension (which I’ve read is the first thing to try).


(Finlay red Stig | JRA Cyc) #4

Put the Ant+ dongle at the end of a 6 ft. USB extension to get the Suunto Movestick Mini within 1.5-2 ft. of the Snap. No difference. Also tried it with just pairing the power meter portion and had the same problem of power dropping out.

I have a couple of videos that I can link here if desired. But I’m hammering in one and the power is very inconsistent and in the other I’m not pushing that hard and still the power drops to 0 regularly. And in both, the cadence is consistent.

Kinda frustrating since I spent the money on the trainer for Zwift and it doesn’t work. Maybe I just need to head back over to Bkool.


(Ryan Luetkemeye) #5

I just bought my snap and having similar issues as above. I’m commenting as well because I would like to see support at least comment on this thread. Would like to see whether they are at least investigating this issue.


(Dave Stores) #6

I am experiencing the same issues.Accelerating towards flat out sprint  and wattage drops down to zero almost instantly.Before christmas had been working well.Now wattage is all over the place.Have tried all recommended solutions to no avail.Very frustrating.Is anything happening with support ?Please help.


(Finlay red Stig | JRA Cyc) #7

For grins, I just enabled my premium membership at Bkool and tried to recreate the problem. Aaaaand… the power dropouts occur there as well. Same setup, same computer, same cable, etc. The problem is that Bkool defaults to 3 second averaging of the power so there can be a delay. But when hammering at least as hard as I’ve done in Zwift, the power will drop to 0w for seconds on end.

I’ve got an active USB extension coming from Monoprice in a day or two and I’ll try it again. But this is looking more and more like a Wahoo problem and perhaps not so much a Zwift problem. Or perhaps even an Ant+ problem. I dunno just yet.

My dilemma is that my Snap is a reconditioned model. So is it that the trainer wasn’t really “reconditioned”? Or is it something else? How about the rest of you: are your Snaps new or reconditioned?

Hopefully Zwift is working on this as well and hopefully they see this thread on Monday.


(Finlay red Stig | JRA Cyc) #8

So, this is looking more and more like a Wahoo/Ant+ issue.  Bkool allows the operation and recognition of BTLE sensors in addition to Ant+. And it does this using the native BTLE in the computer you’re using (Macbook Air in my case). Checking the operation, Bkool sees the Blue SC for cadence and the Kickr Snap for power (but not resistance control). Hammering on the pedals when using just BTLE, there are no power drops.

Now, I don’t know if there is resistance control via BTLE or not (though there should be since it works via the Wahoo Fitness iOS app), but now might be a good time to try and implement it in Zwift (and Bkool). And it’s also time for Zwift to code native BTLE operation in general into the Zwift app on everyone’s computer (rather than via the hack method of using BTLE on people’s phones). Or alternatively, get Ant+ working.

Will report back more when the active USB cable arrives.


(Joe Moletteire) #9

Why is my MPH so much slower on zwift? I use a kickr snap and the speed there is almost exact as my cat eye cycle computer, but on zwift it sometimes shows me up to 20mph slower.  It took me 30 minutes just to ride 5 miles. is there a calibration I need to do?


(Cleve Waterman 69y/o) #10

What value is reported by the Wahoo Fitness app when you do an advanced spin down? Also, have you tried just setting the resistance to 300 watts and then pedal? When I tried this the tire just broke free from the roller. 


(Joe Moletteire) #11

1.9 on the advanced spin down… how do I set resistance to 300 watts? I am new at this and am on the free trial. Not a technical person…so bear with me…lol

 

Thanks


(Cleve Waterman 69y/o) #12

I think mine was 1.7 on the advanced spin down.  

I’m not an expert at this but i am really good at being obsessive-compulsive. 

My recommendation is 1) release the roller clamp  2) air up the tire to whatever recommended pressure you will use each time  3) tighten the roller clamp till contact is just made, then tighten the clamp thru 360 degrees TWO times exactly  4) do an advanced spin down. The number generated should NOT be 1.0  WAHOO recommends updating firmware if the number comes back as 1.0

To get into erg mode: On the Wahoo Fitness app, press START.  Then slide the screens to ERG mode.  You can set the watts to whatever you want. 

 

 


(Cleve Waterman 69y/o) #13

Joe, you probably figured out by now that your speed in Zwift is determined by how much power you’re applying, your weight and the gradient you are riding on. The speed of the wheel has nothing to do with your Zwift speed.  


(Cleve Waterman 69y/o) #14

I have a theory (based on no fact or knowledge whatsoever) that the zero watt dropouts are caused by the tire slipping on the roller during high wattage. I’m on vacation right now in Key West, so I can’t test this out. God I miss Zwift!  Addicted I tell you. Completely addicted! Headed down Duval St now for a drink and watch Sunset in Mallory Square. It will have to be enough. 


(Joe Moletteire) #15

Wish I was in the Keys…Enjoy …I will let you know


(Joe Moletteire) #16

Thanks


(Ryan Luetkemeye) #17

I did the advanced spindown for the first time and I think that was my issue. The advanced spindown gave me a reading of 2.1. My power is reading about 25% more than it was previously and doesn’t brake as abruptly like it did up even small grades. The trainer difficulty is still at the default 50%. I think that is more in line with my true power. I might put the trainer difficulty at 75% because now I just don’t feel the grades as much like I did before the advanced spindown.


(Finlay red Stig | JRA Cyc) #18

So I finally received the active USB cable and placed the Ant+ dongle about 6 inches from the freewheel of the trainer and still the same behavior. I’m really starting to think this is a Wahoo & Ant+ issue at this point. I’m going to open a ticket at Wahoo as well.


(Patrick Stirrat) #19

For what it is worth: I also have a Snap and I use it about 6 hours per week  with Zwift and have not had the problem you all are describing.  I got mine about 6 weeks ago.  Soon after unboxing it, I got the latest firmware, and did an advanced spindown (per recommendations I’d read here and elsewhere).  I did have some issues with periodic power dropouts, but fixed this by literally taping my ant+ dongle to the side of the kickr, using a short USB extension cable.   Since then, no problems at all. I do a normal spindown about once per week.   Good luck - that sounds frustrating for sure.


(Cleve Waterman 69y/o) #20

Could you tell us what part of the Snap the dongle is the taped to?