Kickr reporting higher power than Vector 3


(A Zmansbr) #1

Normally, I ride with my Kickr as the Controllable using ANT FE-C and my Vector 3 as my Power Source (I have not had any of the Vector 3 issues people report). 

Tonight, I wanted to do an Erg mode workout and I could only get it to  work if I selected Kickr BLE as both the controllable and the power source. Then it limited power nicely.

Then to finish up, I did a <world>1 tour of Watopia. Except I was generating insane power. For a guy with FTP of 220, being able to cruz along at 350 and surge to 450 was amazing. I got the green jersey in both directions beating my past times by 3 seconds.

If I switched back to Vector 3 as the power source, it all worked normal. Note, I had my Wahoo Elemnt listening to my Vector 3 so  I could compare to the Kickr and the Kickr was about 1.5x more power. 

I tried debugging this for an hour. I did the firmware update on both devices. I restarted my Mac. I forgot all devices on all head units. I used the Vector 3 BLE as the power source. I did an in-game spin down, and both a regular and factor spin-down using the Wahoo app. No good. I’m still Chris Froome when I use the Kickr as the power source.

Any ideas?


(David K) #2

Generally, you won’t be able to check this setting unless your Kickr is paired as both Power Source and Controllable, but once paired up, you may want to check your Zwift Settings screen to see if your Trainer Difficulty is set to anything but 50%. If it is, set it back to the 50% default and try one more ride.
https://support.zwift.com/hc/en-us/articles/204549679-Settings-Menu

If that doesn’t seem to be the trouble, please let me know so we can convert this post into an email support ticket so I can ask for a few resources to research.


(A Zmansbr) #3

Just to clarify, I only mentioned Erg mode because it was something different than I normally do (yes it was set to 50%). But the excess power production with Kickr set  as Power Source was happening on just a vanilla Ride through the streets - not in erg mode.

I’ll see if this happens on my next ride.