Kickr Core resistance dropout after 19mins!

Im using a Kickr Core, and when doing any ride, be it a structured workout or free-ride, after around 19 minutes the resistance drops, even though it still shows that im doing the target watts

for example, target is 350watts, im doing that for a couple of minutes and then at 19 minutes the resistance drops to around 150 watts, but Zwift still shows 350watts

My setup - ive tried everything!!
Surface Pro hard wired using ethernet cable
ive tried connecting on ANT+ and Bluetooth
switched off all other devices,
replaced ANT+ dongle and extension cable which is about 6 inches from Kickr
Ive used a different laptop, and also used an android phone
ive tried with a fan on the kickr in case overheating was an issue

Ive ran out of ideas on what may be the problem
Contacted Wahoo, who asked me to do a 5 minute ride and send them the file - to which they told me there isnt a problem!! (thats because it happens after 19 minutes- did send them that file too but they ignored it!!)

Has anyone eve r heard of this problem before, or have any ideas at all on how to sort it!!!

The only thing i haven’t done yet is to take it to bits and see if the internals need cleaning - its only about 13 months old, having been replaced when my 1st kickr failed

Hi @TIM_KOS_ICC

I’m assuming you have updated the firmware on the Kickr Core recently, there was an update in June I believe. Also, you didn’t mention doing a spindown calibration, what about the advanced spindown (it’s a hidden feature, but you can access it with the Wahoo Utility app by tapping the Kickr Core icon 10 times).

Cheers Mike
The problem has been ongoing for the last few months, before and after the June update unfortunately
And as for spindowns, ive done the standard spindown and the advanced spindown, more than once,
Im totally out of ideas now !

hmmmm… I would push back with Wahoo, but first see if it happens with other apps, not just Zwift. The Wahoo fitness app has some built in workouts I think, see if the problem happens using that too.

Good luck!
:ride_on:

1 Like

I tried RGT, and that was the same, will try Traineroad and Wahoo next

I would say start with the manufacturer app first.

1 Like

When i last reported it to them, they had me use the Wahoo app for a 5 minute session and send them the data - which I did, and was told there was no issue!
I’ll do another session with that app, but for half hour, when i know the problem will happen - it never happens in the first 5 minutes!

thanks for the advice

If it happen after 19min why did they ask you to do 5min, that does not make sense. Do a 30 min test as you said and send them that file.

1 Like

exactly, i sent the file of the longer workout which was ignored.
Just done a session on their app, and after 24 mins, same thing happened.
Will do a session on Zwift tomorrow to see if the same thing happens, then send them the files to see what they say