Kickr Climb remote not responding

Hello. I have had my kickr climb since 2020. About 6 months ago it stopped responding to grade changes. It doesn’t respond to remote input most of the time either. I have tried reconnecting. Also, I traded climbs with a friend. His worked fine in my setup and with my power cord. He had the same issue when trying to use my climb with his setup. The remote lights seem to cut out intermittently which makes me wonder if it is loosing power. I contacted swift customer service and they didn’t have any suggestions other than to buy a replacement. Has anyone had a similar problem? Any suggestions?


Because the Kickr Climb connects to the Kickr trainer, and not to Zwift, it sounds like this is something for which you should reach out directly to Wahoo support.

Sorry, I meant to say that I contacted Wahoo customer support, not Zwift. They weren’t able to help other than suggesting to buy a new climb and I wondered if someone here may have experienced the same problem.

I did a bit more troubleshooting and figured out that it is a power cord issue, but on the cord that is integrated with the climb unit. If I hold that end in a fixed position it keeps power and will connect. I taped it to the front support and it stayed connected through a whole ride. I reluctant to try to fix the cord and plan to just keep it taped for now.