Kickr (2016) - Sim mode not working after firmware update


(Ricardo Seabra) #1

Hi Zwift team,

Got the new Kickr (2016 edition) and all was well with Zwift. After a week did the latest firmware update, to the version 3.1.1. Now, SIM mode simply does not work in Zwift. I know it’s not broken as I can open the wahoo fitness app and cycle in SIM mode (changing the resistance myself), but as soon as I open to Zwift, all is lost. Zwift is unable to increase/decrease the resistance based on the incline.

Is this a known issue? How can I fix it?

Cheers,

Ricardo


(Ian Hiscock) #2

Similar problem. New Kick (2016), 3.1.1 firmware, but new Zwift user. Resistance is controlled in fulgaz perfectly, but not Zwift. Rider behaves as if there is no trainer control. i.e. hold a constant power+cadence and rider slows for hills.

Trainer with control, tickr and cadence all Bluetooth connected to a Mac. 

Tried restarting in different combinations and ensuring no competing apps running on the phone (bluetooth disabled).


(K Smith) #3

Hi Ian / Ricardo,

Please forgive me if you have already checked these things, but I’m not sure how experienced you are with Zwift.

Are you using Zwift in the workout module?   Or, are you in free-ride mode?    If you are in workout there is an option to select (or de-select) to work in ERG mode.   ERG mode will hold your Kickr’s to the  wattage which is defined in the workout.   Unchecking it means you will have to keep an eye on it and govern it yourself. 

 

There have been numerous issues for Tacx users since the last update so don’t feel too bad…  a ton of people are getting affected by poor SW release it seems. 


(Ian Hiscock) #4

Hi Kerry, thanks for the reply. For me it’s free-ride mode.

I had a quick play with workout but couldn’t stick to the suggested warm up wattage (80W) as the trainer had applied too much resistance. (hopefully a symptom of the same thing)

I’ve opened a support ticket.


(Ricardo Seabra) #5

Hi Kerry, Ian,

Glad to know I’m not the only one with this issue. Free-ride mode for me as well. 

Cheers,

Ricardo

 


(Ian Hiscock) #6

Found a similar thread - https://support.zwift.com/hc/en-us/community/posts/212280583-Latest-Mac-Update-Sierra-and-Zwift

I am also using Sierra and after a quick test appear to be able to workaround the problem using the mobile link app for Bluetooth.

 


(Ricardo Seabra) #7

Still on El Capitan myself.


(Jon Shippam) #8

I’m having this problem intermittently. I’m using Bluetooth with the mobile link app. Swift support have been useless resolving this over the last few weeks. Wahoo support suggested that Zwift Bluetooth support is unreliable and that i should get an ant+ dongle. For me with the Bluetooth connection via mobile link, everything works well until at some point the power drops to 0 then displays --, then if it starts working again then the resistance no longer changes with gradient. 


(Scott Decker WBR (C)) #9

same problem the last two rides - constant resistance regardless of terrain.  using bluetooth via macbook.  any solutions?

 


(pimentium) #10

I have the same problem with SIM mode (just ride) using Kickr 2016 and Mac OS Sierra connected through Bluetooth.

After reading this thread I tried Mobile Link and test ride went as expected. But the issue is a bit annoying.

 


(Jon Shippam) #11

Zwift support really haven’t been very helpful (most of their suggestions aren’t even relevant to the problems I was having, and with messages going backwards and forwards they suggest things you’ve previously told them you’ve already tried…).  Anyway, when I decided to give Wahoo a try, just in case it was a fault with the Kickr 2016, they replied saying bluetooth support in Zwift was relatively new and was still unreliable.  They recommended getting an ANT+ dongle.   I did this and everything has worked perfectly so far (2 x 1hour+ rides).  I also got myself a new Tickr and connect that by ANT+ (even though I wasn’t having issues with the old one), but my old Blue SC (which is the old bluetooth only version) still connects via Zwift Mobile Link app - and that’s been working fine.

Given that the new iOS version will be Bluetooth only, I hope they sort out these issues.  It’s a shame Zwift don’t acknowledge them - Wahoo have clearly seen a lot of people having bluetooth issues when using Zwift.


(pimentium) #12

I reported problem to Zwift. I hope with more reports they address the issue.


(pimentium) #13

Update: Zwift acknowledged the problem after several reports and it seems to be fixed in the most recent version.

I completed 100km ride with direct Bluetooth connection and everything fine.