kickr workaround


(Dion Guy) #1

Had some issues this morning with thw kickr resistance being unstable. Needed to maintain a constant power on the downhills to keep moving forward. However i may have found a workaround instead of logging off and relogging in…i find if i switch on the Wahoo Fitness app, through bluetooth, and simply toggle the sim setting, it resets the resistance on the fly and Zwift starts working normally again.


(Jon Mayfield) #2

Yes, this will do it. We send those commands too of course, but if your connection is weak to the KICKR it may miss them, and that is the current bug people are experiencing with Zwift. Any software that sends the “sim mode” packet will put the KICKR back into the correct state. We’ll be coming up with software workarounds soon.


(Frode Vullum [V]) #3

On my ride yesterday my kickr resistance didn’t work when I started Zwift. Couldn’t feel any difference around the track. Stopped the application and started up Trainerroad, changed from “ERG” mode to “Standard”. Stopped Trainerroad and started Zwift again. All worked OK after this. I don’t no if my change in Trainerroad did the trick or if it had been enough to just restart Zwift though.


(Allan Watkins) #4

Will there be a sim / erg mode available in Zwift as well? If I wanted to do a super steady ride and just wanted the resistance to be normal for instance. Or say I wanted to do a regular ride but do my own self paced intervals instead of the kickr controlling the interval wattage.


(D J. Skinnyphat (MRC)) #5

Dion how do you “toggle” the sim setting? Let me know thanks


(Dion Guy) #6

Jeremy, in the Wahoo Fitness App, flick through the screens until you get to the screen that allows you to set the power, increase the resistance or increase or decrease the level…there are four tabs at the top - Level, Resist, Erg and Sim - all you need to do is click onto the Sim tab and that will reset or rather “re-establish” the connection…I find I have to “toggle” between the screens, in other words just click any other tab, you will see the resistance drops suddenly and then just re-click back onto the Sim tab…hope that helps!


(D J. Skinnyphat (MRC)) #7

Thanks I’ll try that!


(Todd S) #8

This is a useful thread. My KICKR seems to be “stuck” at a constant resistance. It took me a while to figure-out the Wahoo Fitness App (current version is significantly different from the one shown in the video on Wahoo’s site). The Wahoo Utility app is absolutely worthless. Anyway, you can get to the screen that lets you set the erg/sim mode by choosing “Bike” as the workout type, starting the workout, and then “paging-over” to the last display. On this last display/dashboard, the various modes are horizontal tabs near the top of the screen. I hope that this helps!