Joined Group Workout, but not put in Workout Mode.


(T ankBoy) #1

 

Rode today in Jordan Rapp’s group workout. Signed on early and auto-joined the group on the pier about 4 ~ 5 minutes before start. Most of the group was in workout mode, but myself and a few others were not. Rubber band effect worked for group, but not for me, ie, I could not ride away from group but the group could ride away from me. Erg mode worked as if I was riding the course (harder uphill, easier down) it did not lock resistance to certain wattage as it would in workout mode. Also, no workout mode interface was visible - it appeared as a normal ride.

|

I was with the private group with no other riders visible until the workout was over.

Software: Apple TV Beta

|

|   |


(Julie Martins (Zwift HQ)) #2

Hi there! 

Can you make sure you’re on the latest game version? 

In order for group workouts to work efficiently, you must be on the latest build. Try updating and see if that solves it :) 


(Rich Klopfer) #3

You are not alone. I am experiencing the same issue. Very frustrating. I’m running Zwift on a Mac Book Pro with a new version Wahoo kicker. All this technology is expensive. Will try with bluetooth next and then off just my iPhone. Will also try Apple TV as well and report back.


(Jacob Toft-Jensen [MOE A/S]) #4

Any news about the above? I’m experiencing the same thing. Running Zwift on PC with Win10. Zwift software is updated. Have tried both Bluetooth and ant+ and neither works.


(Rich Klopfer) #5

It works off both my iPhone 6 (screen way too small) and new version Apple TV which I highly recommend (simple set up and great graphics). Still no luck with Mac Book Pro which is 5 years old. I’m sticking with Apple TV at this point.


(Mark Kubach) #6

Same thing here. Joined a group workout but not put into workout mode. Made sure my NEO had ERG mode enabled. Reinstalled the PC software and tried again - NADA.

 


(S tephen) #7

I had the same problem with my Windows laptop in that I’d join the group workout but I wouldn’t get the workout intervals on the left side of the screen. I looked at the log file and could see that the downloader was failing to create some directories within my My Documents\Zwift folder to store the workout file. This seems to because my laptop is used in a work domain environment with redirected My Documents folder that is actually stored on a server with a UNC path like “\server\users\my name\My Documents”. This hasn’t presented any problem up until now, but I worked around the issue by creating a new local user on my laptop any running Zwift from that account.


(Mark Kubach) #8

S tephen.  You are absolutely right. I’m also using a work PC and could cee in the logs that the system failed to create  zwift/events/upload/workouts/ “the workout.zwo”.

The main problem is creating the folders. I have just created the folders manually and tried to join a group workout - IT WORKS. The system downloaded the workout to zwift/events/upload/workouts/. So I suggest that the ZWIFT team get this into their installer so all folders are created by the installer. It might even work through an update. Not sure though. :wink:


(S tephen) #9

Nice one Mark. Creating the Zwift\events\upload\workouts folder manually is a simple workaround and hopefully the Zwift devs will incorporate a fix in the near future.


(Kasia Hodun) #10

I had exactly the same problem tonight, but I am not that good with IT. Could you tell me the steps to sort it out? I use the apple laptop, private not work …,


(Mark Kubach) #11

Hi, open windows explorer and look for below path. My Documents should be visible in the top left corner.  Make sure the below path is accessible. If you cant see the full path you will have to create the folders manually.

My Documents/zwift/events/upload/workouts/


(Mark Kubach) #12

Oh crap, sorry Kasia didn’t pickup on you mentioning Apple. Someone with apple knowledge will have to comment.


(Johannes Nowak ZRG (B)) #13

Same issue here - no way to get in ERG mode on a group workout. I’ve installed Zwift on an external drive (e:) created the events/download/workgroups path but this did not solve the problem.

Where do I find the log files to check what is going wrong?


(Mark Kubach) #14

Hi Johannes, I think that even though you have installed zwift on an external drive, the program will still place the workout files under My Documents/zwift… If you are looking for the log files they will also be in the same place. Just find My Documents/zwift/logs


(Cédric Liénart) #15

I too had the problem today when I joined a group workout : Vo2 Max Increase #1

When the ride started, I wasn’t in ERG mode but in SIM mode (+ rubber-band algorithm) so I had no idea how much watts I was supposed to output.

In the logs folder I found this:

[18:09:47] 
Downloader: ERROR: "events/upload/workouts/Vo2\_Max\_Increase\_#1.zwo" failed with 'CURLcode'=23!

[18:09:47] Error downloading workout: 23

[18:09:47] NETCLIENT:UDP StC received count: 201

[18:09:47] NETCLIENT:UDP StC popped count: 201

[18:09:47] NETCLIENT:WARN: Auxiliary Controller: Error shutting down tcp socket: 'A request to send or receive data was disallowed because the socket is not connected and (when sending on a datagram socket using a sendto call) no address was supplied.' (449246432)

[18:09:47] NETCLIENT:ERROR: Auxiliary Controller: Error connecting socket: 'The I/O operation has been aborted because of either a thread exit or an application request.' (995)

The app is up to date, I’m on Windows 7, the Zwift folder is on a regular SATA HDD and I was able to complete an individual workout in the past.

I can see the events/upload/workouts/Vo2_Max_Increase_#1.zwo file but its size is 0KB.

Any idea ?


(Pieter Gerretsen) #16

Hi all,

 

I am running Zwift on the iPad (with Tacx Neo) and have the same issue, although the latest version of Zwift is updated. Before Christmas I did not have this issue.

 

Any idead how to fix this? Thx in advance.


(Peter Ferellie) #17

OK I’m on AppleTV and also experienced few or no riders.  This was a direct result of a Zwift App update required.  Updated and now works fine.

However, I did the 6+1+3 on 10 Jan and ERG mode kicked in fine.  Did same group workout today 13 Jan and ERG mode wouldn’t work.

Very frustrating and keen to see if there’s an answer.

All apps were updated.

Thanks.


(Paul Collier) #18

I’m having the same issues on Apple TV, it works 1 in 5 times. Incredibly frustrating, does anyone know how to resolve?


(Itai Katzhandel) #19

any updates on this?

Im using iPad with the latest version and had the same issue yesterday.