Issues with bluetooth dropout on Woodway treadmill

Shooj - glad to hear that there are Woodways that do work. Gives me hope.

1 Like

So to update everyone on the status of my issue. I’ve run an Ethernet cable from my router to Apple TV, same problem
I’ve run an Ethernet cable to the woodway, same problem
I’m beyond pissed off now, this is silly that this thing can’t figure out how to stay paired, so now I have to buy a treadmill sensor or footpod because the Uber expensive treadmill I saved and saved for, can’t get the job done, pathetic.

I have been communicating with my Woodway sales rep since this issue started for me. His most recent update acknowledges the issue and it sounds like the R&D department is now actively investigating, working with the Bluetooth hardware supplier.

Don’t ask me how/when this leads to a fix, but that’s the update I got.

1 Like

@D_Larson
Interesting. Please keep us informed if you hear anything back.

In the meantime, would you try something?

  1. do you have another device that can run Zwift, like a smartphone or a laptop? I’m wondering if we can isolate this as an issue with the Apple TV platform .

  2. Is there another run / fitness tracking app you use to log your runs on the tread? If similar flaky Bluetooth issues crop up there too, we can surmise that it’s an issue with the Woodway.

Thanks for the questions. Woodway, to their credit, has done a great job keeping me updated. I know there is now an open line of communication directly between Woodway and Zwift. I’m hoping there will be a fix, and that it will be able to apply to my treadmill.

Since you asked, I will tell you I have tried the Apple TV, the iPad, and a couple of different iPhones. Yes I am heavy on Apple at my house. Same issues on all devices.

I don’t use any other running apps. The communication with the Apple Watch seems to be seemless although that may be a different communication protocol.

Hey everyone, just to keep you in the loop, I’ve tried connecting via laptop, iPad, iPhone, hardwired Ethernet etc. It’s definately the woodway, just curious what did woodway day to you with regards to their on board bluetooth module? Or if they were working on a fix?
I ordered a GEM retro from North Pole engineering to plug into the csafe port and if it works I will be sending the invoice to woodway. I didn’t have these issues with my last smart treadmill, a sole f-something or other, although that treadmill also wasn’t as comfortable as this woodway is. Hopefully it gets sorted soon, zwift is beyond cool and I feel it’s the future of indoor running for sure!

Any update on this? Did it work? Woodway seems to have given up on this and now only tells me that Zwift needs to fix the problem. I don’t have a lot of time for this issue plus I have mostly been training outside in the summer but would love to get the treadmill working with Zwift by the winter.

Hey! Sorry I thought I had posted my fix to the issue. Yes I have it working now, I had to buy something called a gem retro (treadmill) from a country called North Pole engineering, the company who purchased wahoo a year or so ago.

What you do is unscrew the back of the display panel on your woodway, I have the quickset display on mine and plug this module into the csafe port, it’s labelled inside the woodway control board. After you screw it back together when you pair your treadmill on zwift you select the treadmill option and not the woodway option.

I have had zero issues or dropout since. Hope this helps! I called woodway a month or so ago and said I’d be sending them the bill for me having to buy this to make it work after shelling out thousand of dollars for their treadmill. Explained that my low end sole had no problems connecting to zwift, they mentioned they’d send me a reimbursement cheque but I haven’t received it to date.
I will be following up with them about this

Let me know how you make out!

Cheers
Chris

That sounds great and thanks for the tip!

How old is your woodway. Mine was built about 18 months ago. And has worked perfectly with zwift. No dropouts ever. And connects every time on first attempt (as opposed to my ticker fit and stryd that I always need to play with for a while). Maybe something with woodway older or newer gem modules.

Mine is brand new, June 2020

That would make sense, if you needed something called a ‘retro gem module’. Which from the name sounds like an older version. Maybe that is what I have in mine. And the newer woodways have an updated version that does not work with zwift.

Yeah it’s very silly considering woodway is not cheap by any means. That aside, it’s an unbelievable machine, but like I said earlier, my low end sole that we had previously had no issues connecting to zwift, so if they can figure it out, woodway has no excuse.
The gem retro is meant to make older non smart treadmills into smart treadmills essentially.
Just plugs into the csafe port

That’s the route I would go as woodway blamed zwift and when I talked to the folks at zwift all they told me to do was unplug anything electrical in my house to avoid interference (slight exaggeration).

At any rate I’m happy it’s sorted now, feel free to pass this fix onto anyone who’s having issues with their woodway.

Cheers
Stay safe
Chris

Hey I just want to report back and give a big thanks to you for the help. I bought the treadmill GEM module from North Pole Engineering. Have installed and we are finally up and running. I am so happy to have it working. I appreciate the help.