Issue calibrating new Tacx Flux 2 to Zwift

Just in case this wasn’t mentioned above - Zwift calibration DOES NOT SUPPORT this type of trainer. So it’s an error because of software from what I understand, not because it’s supposed to work and there’s a physical problem. Yes, ideally they should show an alert saying “trainer not supported for calibration process” or something, but there you have it.

Gerrie, I am engaging in this dialogue as I have read numerous posts for your support in resolving Tacx power issues on Zwift (Thank you in advance for your expertise btw). Let me offer some background, I had been using a Kickr Core for ~8 months on Zwift…easy and predictable power whether through iOS or Mac laptop (Ant+ dongle)…no issues. This weekend I decided to buy the Tacx Flux 2 and set up was easy…installed updated Firmware through Tacx utility application. Then started Zwifting via phone (iOS)…application crashed and wouldn’t reconnect to the activity…had to reboot the Zwift platform…never have had this happen with Wahoo/KickrCore-Zwift. Then (here is a tip)…the Tacx utility wouldn’t connect to the trainer and I couldn’t calibrate…so frustrated I eventually pulled the plug (literally) on the Tacx and allowed the trainer to reset…then connected just fine on the Tacx utility and I upgraded the firmware to Communication > 3.3.4 | host processor > 1.16 and then calibrated the spindown just fine. I have run the trainer now through only Mac OS with Ant+ dongle…no dropouts nor crashes (knock on wood)…but (I am a big gear pusher…always big ring and low cadence) the resistance is definitely harder on the Tacx Flux 2 vs the Wahoo Kickr Core…very different feel…maybe that is because the Wahoo was artificially “easier” with Big Gears - Low cadence cycling…maybe the Flux 2 is closer to reality…hard to tell with my subjectivity…but, you might tell others who cannot upgrade firmware to “power cycle” the Tacx trainer by unplugging…then allow it to reboot…try to connect/calibrate via the Tacx utility app. But…I want to know from you…there seems to be a faction of people that are implying the Tacx is reading lower wattages than the effort being put into the ride on the Zwift platform…also, I observed people saying the Tacx is worse at representing watts with Big gear - slow cadence…would like to hear your feedback on this as well as any other thoughts that may explain what I am seeing (feeling on the Tacx). In the mean time, I am going to experiment with high cadence-low gear combinations to see if this changes the perceived exertion versus reality of watts recorded.

Hi @Jon_Stacks_8516

Welcome to the forum.

I don’t have a Tacx trainer, maybe other users can help out a bit.

I have the same issue. Tacx own app works perfectly, but not able to do a calibration with Zwift, ERG is not functioning, showed wattage goes up and down while I spin at a constant level without real world wattage fluctuating to similar extent and while climbing the resistance doesn’t get any harder.

I updated to newest firmware version but that doesn’t solve the issues.

For clarity’s sake: I see above the tip to simply ignore Zwift’s calibration and to only use tacx’s own. If I do that, however, I cannot properly train in zwift because of ERG not functioning, unreal spikes in shown wattage, etc.

1 Like

@Job_van_Hooff

Definitely use the Tacx app to calibrate your Tacx trainer. Once that’s done, it’s important to close the Tacx app (don’t just swipe into the background) so that it’s no longer paired to the trainer’s Bluetooth signal.

It’s possible that something else is stealing the trainer’s Bluetooth LE signal before Zwift can fire up and see it. Be mindful of anything else running that you might do that: the Tacx app, Garmin Connect app on your smartphone, the bike computer on your handlebars, etc…

Also be sure that you don’t have the Zwift game app running on more than one device. Multiple instances of Zwift logged into the same account can also mess with things.

txs very helpful
i’ll try later tonight but just out of curiosity, after you have calibrated the trainer using Tacx app, do you still see the little tool icon below the power source pairing icon when you launch zwift?

Yes I have the same Problem. But since I tried now 3 weeks to solve the issue I would like to share my Learnings.

  • I was NOT successful. Issue is still the same.
  • I tried everything what different People proposed as possible Solution on different Platforms in the World Wide Web.
  • ZWIFT support was not a help at all (I believe they don’t understand the issue)
  • The Issue is definitely on ZWIFT not on your Tacx Trainer.
  • I see only two possible solutions:
    • Use a different Software
    • Get a different Trainer

Here are some Details

Last Winter everything worked fine. This Winter it did not work at all yet. And I’m not able to tell what is different on my set up since last winter.

I’m not using Zwift all year only during the Winter. And I also pay for it during that time. But I assume this has nothing to do with the issue.

May Standard Setup is the following

  • Tacx Flux S Trainer from 2018
  • I use the Zwift Software on my Windows Laptop (Connected via ANT+ to the Trainer)
  • I use in addition the Companion Software on my Android Cell Phone
  • I use the Garmin vivoactive 3 to share Heartrate.
  • Utility App for setting on Tacx Trainer
  • Software, Apps and Trainer have all the latest software

The following I tried to solve the Issue and after each change I restarted the entire setup (nothing of it solved the Issue).

All of this was mentioned as a possible reason for the Issue somewhere in the Internet

  • Shut of all Bluetooth connection (as there might be a conflict between ANT+ and Bluetooth)
  • Pairing with Bluetooth only instead of ANT+
  • Calibrating the Trainer via Tacx Utility APP (works perfectly fine)
  • Calibrating the Trainer via Tacx Training APP (works perfectly fine)
  • Check ERG Mode in Tacx Training APP (works perfectly fine)
  • Removed USB extension cable for ANT+ Adapter on my Laptop
  • Turn Off complete Cellphone and Garmin Watch (to avoid connection conflicts)
  • Connected to Cellphone Zwift Mobile App only (no Computer)
  • Logged in a new (fresh) user account
  • Using old Protocol for Pairing (instead of ANT+ FE-C)
  • Restart Paring during workout pause
  • Using a different Laptop for Windows Software
  • Switch off “Enable ANT+ Speed/ Cadence”-Option in the Tacx Utility App

It is correct that you can calibrate the Trainer with a different Tool (instead of Zwift).
However this will not solve the actual Issue

It seems that most of the user have a combination of the following issues.

  • Calibrating does not work. This is just where the visual issue occurs. It seems to me that the reason is that the flywheel is not braked by Zwift. The wheel just runs out without load. This is different on the other Tools I used where it works fine.
  • ERG mode does not work at all. You must switch Gears to change power.
  • If you use the slope mode there is no effect on the Trainer if you manually adjust the slope
  • If you are not in a Workout (just normal ride) there is no effect on the trainer if slope is increasing. Only the avatar drives slower. But on the bike it feels the same as before.

So it seem that Zwift is not able anymore to adjust the resistance on the Trainer anymore. And this is the actual Problem. At least on my setup.

So my conclusion if Zwift is not providing an answer soon, I have to switch to another Software (and give my money to somebody else)

(Please excuse my English, I’m not a native speaker)

1 Like

By the way, I’m still interested in getting support from Zwift. Also, if any user in this forum was able to solve the issue please share your solution . THANKS

I just created a new ticket for the support with reference to this section. I hope the will react on it with in 24 hours. We’ll see if Zwift is willing/able to provide support on this.

I have a similar issue when using my Tacx Flux 2 + IPad Air 2 with Bluetooth - neither ERG or “standard” mode works (no resistance added). Zwift calibration fails as well.

Raised a support case a few days ago, still waiting for a reply.

The support was asking for my Log files which I send two days ago. So far no Feedback. In the meantime I installed bkool which works perfect with my Tacx Flux.

My personal disadvantages compared to Zwift

  • Much smaller community

  • in the Workout you don’t get a Street simulation. You have to look at some colored bars.

  • Doing a community race seem to be more complicated (or I’m just not yet used to it.

My personal Advantages

  • You can ride real tours which you can search for or pick on a world map

    (I found a nice Tour in Italy lake Garda which I did in real already several times)

  • The software on the computer starts much faster (just takes a few seconds).

  • Cost 33% less than Zwift

Since bkool works for me and I’m getting more and more used to it I give Zwift until end of the week to solve the Issue before I quit my account.

Hi Christian, I have exactly the same issue as you with my Tacx Flux S
Updated to the latest firmware, recalibrated with Tacx Training app, all ok.
Went to Zwift, recalibrated from the pairing screen: the app asked me to stop pedaling when I reached 30k/h, not 37k/h, and said ‘succesful’
Before all that, I could reach 200w easily in Zwift with 90 rpm and a mid cassette gear, just as I can do in the Taxc training app.
Now in Zwift, no erg mode, flat route, pedalling feels very hard, power output too low for the feeling and cadence, I can only reach 200w when I switch to the big wheel.
Somehow Zwift controls (incorrectly) the turbo resistance.