Issue calibrating new Tacx Flux 2 to Zwift

Yes, it works within tacx app, but not in zwift.

Then use the tacx app. You don’t have to calibrate in Zwift if you calibrated in the tacx app the calibration values is saved in the trainer, so you will be good.

Same problem as others but additionally now the TACX Utility app doesn’t work - in fact it crashes out when I start it. Ticket raised but no response so far. Anyone else getting this with version 2.1.0?

1 Like

Same setup and same issue. No problem calibrating on Tacx app though.

Guys, no answer from Zwift, when they know they are accountable to solve this bugs. Whats the solution? Say something Zwift team

@Fernando_Franco_VEN

Welcome to the forum,

Have you tried calibrating using the Tacx Software app. Calibration can be done with the trainer app, the calibration values is stored on the trainer not on Zwift.

Yes . We have tried everything. It all started when I did the last software update

Are you saying you cant calibrate using the Tacx software app?

I meant, when I tried the flux2 right after unboxing it, it worked flawless, after I did some software update it started to fail and lose Watts suddenly after 5-10min using Zwift.

I must say, zwift is the only app that has this bug, Tacx utility & software work perfect.

Hopefully someone has some answers

1 Like

Same problem. Can’t calibrate with my tacx flux 2 and can’t do a realiable training. Cadence doesn’t sense right (too low) and ERG resistance jumps from 90% to 140% , even 200% without explanaition and when it should not do that. It’s really anoying. And yes, it’s only zwift problem. Tacx app works fine.

I have just lost an entire hour of orange unicorn training because resistence on ERG goes crazy and inclination option doesn’t work… and it’s not BT interference, it’s not the internet conexion, and not the firm update. It’s really really anoying. I begin a training not knowing if i can finish it or not, if my trainer on zwift will become crazy… I’ve lost a lot of training time because of zwift. I think that if the problem continues i will drop the app. Sorry, its really fun, but in this condition i can’t use it.

I have exactly the same situation. I just purchased a Tacx Flux 2 and i cannot calibrate. The calibration does not pass to Step 4. Also when i go into ERG mode in a workout does not seem to be heavier in the slopes and lighter in the downhill. should i report this to Tacx? (now Garmin)

The ERG mode adjust the resistance to the watts required in the training, not to the slopes. But anyway it drives crazy from nowhere and cant finish the training.

Same issue here after just joined Zwift from using TR all winter/spring without power/erg/calibration issues on my paired tacx flux 2 I’m not impressed as this issue seems to going on 6 months plus.

I have tried all mentioned troubleshooting above but no success. My first session and power was jumping all over the place and erg mode was losing power.

No way to do effective training with these issues.

Zwift please reply with fix.

Thanks

Same problem here. Tacx Flux does calibrate with the Tacx App but not directly on Zwift. From what I read, it doesn’t seem to be a problem for in game experience. I just hope my training power/speed calculation is right. Power calculation and erg mode is all over the place during specific training.
Tried a dozen times on Zwift but no succes, which was really frustrating…

I hope Zwift can fix this soon.

Unfortunately I’ve had to cancel my subscription. Best of luck everyone.

(Zwift staff do not seem to check these threads)