Is android ant+ possible to connect to controllable trainer?

I used to have a laptop. The Ant+ dongle connected to my Bkool as a controllable trainer as well as HR speed, power and cadence.

My laptop is now broke. I’m using my Samsung Galaxy S10 instead.

Its detects my HR, power, speed but not as a controllable trainer!

Is it impossible?

The things I have tried so far: updated bkool smart go, change the settings on bkool for ant+ fe-c, checked and installed all ant+ apps/settings for phone, got a USB adapter to connect Ant+ dongle. So far nothing worked.

Has anyone managed to use android to let Zwift control the smart turbo trainer?

Many thanks
Matt

Last thing on their to do list, wasn’t even on it till we asked so add your voice here - ANT+ Update

1 Like

Done thanks. I will probably use bkool free trail until they update

Hi, trying to get Zwift set up with my CycleOps Powerbeam Pro ANT+. I haven’t been able to get it to connect to controllable. It’s not found at all when searching. It is picking up the power meter from the CycleOps, but not controllable. I was previously using Rouvy, which connected fine. I have unpaired it with Rouvy. I have a dongle plugged into my laptop. The trainer is ANT+ only, no bluetooth. It looks like this has been an issue for some in the past and wondering if there is a solution? Any help would be appreciated.

Hi @Jennifer_Ross and @Matthew_Rush welcome to Zwift forums.

That’s expected behavior right now for the Android game app, which is in beta for ANT+ trainers. Trainer control over ANT+ FE-C protocol is not supported at this time.

1 Like

Thanks will it be in the near future?

HI Matthew - just chiming in here. The answer is hopefully, yes.

We are reviewing ANT+ FEC support internally. We initially didn’t support it due to dev bandwidth, customer support bandwidth, the challenge of making it compatible with some ‘non-standard’ FEC protocols, and other reasons.

We now have seen many, many requests for ANT+ FEC, from the community, so I’m hopeful that we can commit to supporting it soon, and get on with it!
-Will

2 Likes

Great news thank you

1 Like

My game is on my laptop. Is that still considered Android since it’s Windows?

Hi @Jennifer_Ross
If the laptop running the Zwift game app is WindowsOS, the Windows version supports controllable trainers via the ANT+ FE-C wireless signal.

What trainer do you have?

I have the CycleOps PowerBeam Pro, which is ANT+ but not Bluetooth. The laptop is WindowsOS.

@Jennifer_Ross

According to the manufacturer’s site, the PowerBeam Pro ANT+ model predates the specific flavor called “ANT+ FE-C” that allows the game to control the trainer’s resistance. So while you should be able to use the trainer in Zwift, the controllable resistance feature will not work.

Also, we have not added ANT+ FEC support yet. It’s on our list. We’ve had dozens, maybe hundreds, of requests for this. The code is fairly simple, but the testing needed is pretty extensive.
Due to the lockdown, our testing in general on trainers (bluetooth or ANT+) has been severely compromised. We are working to address this.
Will

2 Likes

Is this a Zwift software issue? My trainer was controllable while using Rouvy.

@Jennifer_Ross
No, this is a limitation with most trainer hardware manufactured before 2017-ish. Those are the days before third party apps like Zwift changed that industry. Back then, trainer companies either made their own training apps, or partnered with specific app developers for limited compatibility in a closed system. See the notes on the specs for your trainer:

Now that the bike trainer industry has open standards like ANT+ FE-C, contemporary trainers will work with any third party app that also complies with those same open standards.

With today’s update it still doesn’t work ??

I am having a similar problem. I have a Tacx Vortex, connected to my Samsung Tab S4, I usually used to connect it via bluetooth, but I couldnt connect my HR monitor directly to Zwift (so I monitored my HR with my Garmin) and then I discovered that If I used de ANT+ antena, I could pair my HR monitor to Zwift, but now I’m having a lot of trouble, because at first, it connects rapidly to my trainer, but then, it says that it has no signal, I have had to reset the Zwift app 4 o 5 times to get me rolling with no problms, but yesterday the trainer disconnected from Zwift in the middle of my training.

I’ve just purchased a saris h3 and when using an android device (Huawei mate 20 pro) I can connect the saris to the power source, cadence and controllable trainer with no issues. However when I start a ride on zwift via the android device the resistance is not being controlled up or downhills. It feels like I’m always at a 0% grade. I plan to test rouvy tomorrow.

The spec of the h3 includes Bluetooth smart that can control resistance so it’s not a trainer issue. The resistance is controllable via a mac (I haven’t tested with my iPad mini 2 yet). So maybe it’s just an android issue??

A post was merged into an existing topic: ERG Mode issues w/ Saris H3