iOS Companion App - Resistance Issues Creeping in

Hi All,

I hope you are all well.

I’ve been trouble-free on AppleTV, iOS Companion (iPhone) and Kickr for many months (on macOS prior to that for years). I recently started having resistance issues.

I first started experiencing issues with the resistance in-world. Sometimes too much or too little or no changes for the gradient. Found that stopping and power cycling the Kickr mid-ride fixed it. Usually, the resistance is just spot on any time I start a ride.

Then just yesterday, I found that am not able to get ERG mode or incline control going at all for a workout.

So today, I tried eliminating the Companion app, connecting direct to AppleTV (sacrificing cadence and having just HR & Power) and had no issues at all. Everything working fine! Not having any issues when testing resistance control through the Wahoo iOS app either.

Has anyone else started having these sorts of issues on this setup creeping in over the past months/weeks?

Not seeing any other issues with HR or Cadence through the Companion app, just seems to be resistance control. AppleTV and iPhone are on the same network. All on the latest software and firmware versions.

Tempted to just update to the latest Kickr with cadence, or some other bridging solution so that I can eliminate the Companion app and connect all 3 of cadence/HR/power direct to AppleTV.

Cheers,
Danny

So I conducted another experiment last night. A different iOS device. Switched to the iPad instead of the iPhone to run the Companion App. No issues at all through the event! Woohoo!

So anyone had any similar issues on the iPhone and resolved them?

Well, not such a success with the switch to an iPad. Started experiencing the same issues with a lack of resistance control.

Keen to hear if any other zwifters are having similar issues, or if there are any other items on the forum that discuss this.