iOS Companion app 3.29.0 (1158) issues [SOLVED]

Cheaper to subscribe to another program :rofl::rofl:

4 Likes

Exact same here

1 Like

Might need to switch if this continues.

4 Likes

@Gerald_Venditti

That sounds extreme! :thinking:

Was it a new or pre owned iPad? I have thought about doing this but can’t work out how is stop the iPad automatically updating to the iOS that’s causing this problem…

I’ve also thought about trying to roll my iPad back to the previous iOS, but Apple don’t seem to let us do that.

How did you do this?

I am having this issue and running zwift on a MacBook Pro running MacOS 11.6.1. I have tried the companion app on both an iPhone and an iPad and both are running iOS 15.1 and having the same issue where the map does not load. Although I was able to get it to load on my iPhone two days ago after several attempts and restarting the app.

ffs, now the Filter button won’t work on non-game mode for ZCA and it shows all events so I can’t search for anything.
This is a farce

2 Likes

Thought I was losing my mind.
iPhone to run Zwift
iPad mini for companion.
Same network.
Has worked fine til a couple weeks ago
I’ve deleted the apps, reset the Wi-Fi connection,
Power off and on, turned off private relay on iOS 15

The map loads for one second and disappears

Thanks for any help

1 Like

Same here. Driving me mad. Need it to plan my events.

1 Like

The only way I can get companion app to launch at the moment is to turn off WiFi on my phone. I have to then turn it back on to connect to the game.

This is the same whether I try to launch companion before or after I start Zwift

I’m on iPhone 7 ios 14.7.1
Windows 11 running on laptop
Neo2 connected to Zwift via ANT-FeC for power and controllable and assioma pedals connected for cadence; Garmin HRM connected to Zwift via BLE
No apple watch (I have a garmin vivosport that is connected to my phone via BLE but not sure that should be interfering)

You know, here’s a thought. Earlier today I ventured in to Neokyo for the first time since its release. Interesting as it was, with all the colours, the new route and all, I was completely unable to share this with riders around me, let alone friends because as usual, ZCA crashed on launching.

And here’s the issue for me. Zwift has spent a lot of time and effort developing new venues for us to play the game in. That’s great and I appreciate that. (Though I do pay for that pleasure) It’s a bit like going to a great restaurant with friends and family, getting the chef make you your favourite dish, but then finding out you have to eat it alone, you can’t share the experience with the people you went to meet and the restaurant staff/management don’t seem to care you’re eating by yourself because they presented you with a tasty meal.

So it occurred to me, Zwift launching Neokyo is just launching something else to go wrong in the future. And worst of all, they launch it with so many unresolved issues from the past still in evidence, including this one.

I only wish they’d invest the people, resources, time and effort into making what we already have work better than creating new routes and worlds.

Maybe not the best place for this post and a bit random but reading the posts of others here, Zwift may be coming extraordinarily close to finding out where the fine lines between customer acquisition, satisfaction and retention lie.

Having the biggest restaurant in town, serving great food is fine. Until customers start finding hairs in their desert and the waiters say it’ll be fine next time you come, rather than get you another choice of desert and say there’s no charge for the meal.

Come on Zwift, sort this out.

7 Likes

I turned off my Ipad completely. After turning on again the Companion App seems to be working again.

I expected Zwift Companion update 3.30.0, but it didn’t fix the bug in iPad iOS 15.1.

I use a PC for Zwift, and an Ipad for the companion. But now this means that I can’t interact with the game when I’m riding as it’s almost impossible to use a mouse, especially in a race where I’d probably come to a stop while trying.

The impact is that it makes lots of basic things almost impossible; using power-ups, giving ride-on’s, selecting a turn other than the default, sending a message etc. Basic parts of the game rendered difficult/impossible.

I’m trying to use an Android phone as a substitute, but after several weeks, get the iPad working!

2 Likes

For those on this thread: Can you confirm if your issues are with iOS (iPhone) or iPadOS (iPad). For me, everything works find in iOS, but iPadOS does the ‘show map for a few seconds, then disappear’ thing.

5 Likes

The vast majority of the problems reported on this thread are iPad specific, although there are a handful of red herring posts.

3 Likes

Agreed. But because the subject of this thread refers to iOS, not iPadOS, I wanted to be clear, since these are similar, but different, operating systems.

I have the same experience ZC works on iPhone but not on iPad.

2 Likes

@Nigel_Tufnel

My issue is with iPad iOS. (Map loading and then collapsing within seconds) though in game it still shows that ZCA is connected.

I have a secondary issue with iPhone iOS where ZCA wont load on occasion. It sticks on the blue opening screen. It sometimes requires 4 or 5 attempts to get it to load with the iPhone needing to be restarted and WiFi turned off.

1 Like

No, my iPhone 12 mini on 15.1 is equally as bad as my ipad pro(s)

1 Like

Ive the same issue with needing to reboot iPhone several times, it also happens with my iPad, just to get the CA to shift the blue screen. Anyone else find that when you set off on a route, your avatar does a u-turn therefore negating the route you’ve planned. Happened to me on Watopia & Neokyo.

1 Like