IOS app freezes mid ride multiple times

At the risk of providing an additional data point versus tacking on to an existing topic, here I am.

IOS version: 11.4.1 (15G77)
Zwift version: looks like in bottom right corner of app open it says 1.0.41889
Phone: Iphone 6S, 32GB with 12 GB free

What specifically happened:
In the past I’ve gotten plenty of “notifications” from other apps not cause issues. Tons of meeting invites, texts, etc… No problem.

Today, I specifically remember the phone wanted my apple ID password as being the popup mid-ride. I hit cancel or denied the popup and kept riding. I think it came up again a minute or two later. Then the app later froze during a group workout. I tried making sure all other apps were closed. I tried minimizing and bringing Zwift back up. It wouldn’t respond. Finally, it seems in doing this it closed itself. I didn’t close it. Then it opened at the beginning screen and offered to rejoin ride. It eventually did, then froze again. I got fed up and quit the ride.

When submitting the ride data at the screen you can update the ride “name”, it had frozen again at entering text here. I hit the submit button and it must have unfrozen and submitted it. It all showed up on Strava afterwards.

I have a race Thursday night and really need this to work.

I also had a problem not Zwift related that perhaps exacerbated it. I noticed my HDMI/charging adapter cable wasn’t charging the phone while displaying on HDMI. I fiddled with the connection on the bike side and it seemed like power was going down despite seeing a charging lightning bolt.

I mention this because phone power was around 7% when the freezing issue started. It wasn’t hot. Thought this was an important piece of info.



I would recommend you upgrade your iPhone to 13.2.2, 11.4.1 is a very old build and see if that resolves the issue.

1 Like

Charging it up now and putting it on a wall cable to do exactly this. I’ll report back with a resolution tag if it works out.


Make sure you back it up first.

Upon updating to iOS 13, you will probably need to go to the settings in your phone and re-allow the Bluetooth connection for Zwift, Apple updates across the board have been locking us out of this and causing a lot of support conversation flows.

1 Like

Ok, it updated fine. I did as suggested and re-allowed the Bluetooth connection. I’ll do a quick 5min spin tonight to verify function.

I’ll need to maybe leave it setup while not riding or something to test out the battery drain/hdmi issue with the connector. I don’t have time to actually ride tonight but can let it sit for an hour or two to see if it’s jiggling the connector or if it’s the phone causing power issues with that cable.