Interrupted ride

Hi all, new here so apologies if this is in the wrong place. Was doing a ride last night and stupidly didn’t realise my iPad power was close to zero and it shut down! Jumped off the bike to grab my power cable, got back going and Zwift asked if I wanted to resume my ride, which was great. Duly cracked on and completed a 102km ride. Hit save and my ride is recorded in my companion feed all good. Went to check Strava only to find it had uploaded the ride at point of interruption which is only 52k😟. Tried a manual download only to find the latest fit file is showing activity in progress? Went to my Zwift feed and tried to download the fit file from there for the 102k ride but when uploading that to Strave it only brings in the 52k ride?? Any ideas on how to sort this out please? Thanks

Have you tried importing the fitfile into fitfiletools dot com and seeing if it can fix the ride. I tend to use the corrupt file fixer first then use the time fixer to ensure it shows the right day.

Thanks, will give it a try👍