Is there someone I can call to get this Kinetic Inride powermeter to work with Zwift? Im paying for this service and cant even use it.  Please help

Hi David,

The Kinetic InRide uses Bluetooth, so you will need to set your iOS device to use the Zwift Mobile Link to act as a Bluetooth bridge between your InRide pod and Zwift.

For instructions on how to do so, please visit our Knowledge Base article here:

That should help you here set up!


I’ve tried and its not connecting. I need phone support.  Do I have to have a MAC or is my PC ok to use.



Since we’re a small company, we don’t have the resources for phone support, but I’m confident we can fix this here. :slight_smile:

First, Mac or PC is fine as long as you have an iOS device and have followed the steps Eric mentioned for using the BLE beta feature.

When you say you’re having problems connecting, is the problem with the Bluetooth icon not showing up correctly on the pairing screen (does it have a hazard icon) or is the inRide just not showing up when you search on the pairing menu?


Also using the Kinetic inRide and BLE beta feature on my dumb Kinetic Rock and Roll trainer. Have an ant plus dongle and trying to use my iphone as a bridge but having the same issue as the OP and for me I am getting the hazard icon… 

The InRide does not use the ANT+ dongle. The error is fine as CompuTrainer also doesn’t use them either.

The hazard icon means that you’re not setting up BLE correctly, so I’d recommend going back through the steps and making sure you’re following them exactly as listed.

Hi Jason, I’ve been able to pair all my BLE devices (cadence, speed and hrm) …however for inride, I am connecting but it always displays 0w.  Another question, how to engage calibration of the inride device (spin down) to get more accurate readings?

thanks for your hard work getting this feature in!

Does Zwift support version 1 or 2 of the Inride (or both)?


I have finally found my issue…0watt was displayed because I needed to have wahoo app installed and have the inride device calibrated prior with that app. After performing wahoo app install and calibration, watts started to appear.

David: I have inride v1 and it works well!

I can’t even get Zwift to see my InRide (V1).

Of course I’ve had no end of problems with the InRide anyways outside of Zwift.

David, here are the steps I’ve taken to get the thing running…hope it helps

  1. Install zwift on both your iPhone and your computer 

  2. Make sure you enable Bluetooth in your zwift iPhone settings

  3. Open zwift on computer, and when saying it can’t find ant+, click ok and go as visitor only. enter Bluetooth unlock code as fond in zwift instructions.

  4. Press the A key to go back to configure page, and the. You should see a logo on top left of screen that shows that your iPhone broadcasts Bluetooth.  I have found that sometimes you need to just kill the apps using ble on your iPhone to get the thing to work.

  5. Search for devices and it should display!

Yeah, I’ve tried that (although the unlock code is no longer required), and my other BTLE devices are recognized… But not the InRide. 

I’m going to exchange it for the free V2 upgrade offer that Kurt is offering. 

Do you have any insights of what v2 offers compared to v1? And any info on that trade in program? Couldn’t find anything googling… Thanks

I’m not sure what the advantages are … but here’s a link to the info:

How would you guys recommend calibrating the inride sensor before riding with zwift? I have found that if you warm up on zwift, then try and calibrate by going into the inRide app, you have to drop your zwift bluetooth connection. So, I think the only way to calibrate it is to warm up prior to opening zwift, then calibrate on the kinetic app, then open up zwift. I belive the calibration will still be set when you go to use zwift, so it should be accurate. 

Is there an easier way?

I have the inride as well and followed all instructions.  The iPhone BLE icon is lit up on the pairing page, but when I search it finds nothing.  Does the Bluetooth on my computer need to be connected to my phone or something?  I’ve spent an hour on this and am about to go back to watching Netflix.

I am having the same exact issue as Andrew just described.  The BLE icon is pulsating and thus connected to my iPhone6, but clicking on “search” displays nothing but an empty list. I should also point out that I did engage the pedals on my bike a couple to revolutions to ensure that the InRide sensor was active, but regardless I get nothing in the search list.

I am assuming the the Kinetic iPhone app does not need to be running and that I do not need an Ant+ dongle for this to work, but I have tried that both ways as well.

Any further assistance would be greatly appreciated.

Is your InRide paired to the phone at all? If so, unpair from your phone and from the inride app. Then try again. If it’s paired to the phone then it will not pass through to Zwift.

I got it to work.  After the iPhone icon was pulsating, I clicked back on the app and it must have made the app active again or something because it then picked it up and everything worked fine.  Quite the process though.