BLE Kinetic Inride Issues


(Sharon Nehring ROL) #1

I am using a Kinetic Smart trainer with InRide and the app. For the past 5 weeks, BLE will not maintain connectivity and I must turn it on every time I log into the app. Once I log in to the software, InRide does not pair or it pairs for a minute then goes off. I cannot log a ride on Zwift at all! Please fix this.


(Eric C. (Zwift HQ)) #2

Hi Sharon,

This sticks out as a possible issue:

“…with InRide and the app.”

If you are using the InRide App on your phone it will never pair with Zwift as it takes control of the InRide. To ensure that your InRide works with Zwift, do the following:

  • turn on Bluetooth on your phone
  • Connect your InRide to the InRide app on the phone
  • Do a spin-down calibration
  • close the InRide app on your phone COMPLETELY
  • start Zwift and pair your InRide as a power meter

That should do it.


(Sharon Nehring ROL) #3

Unfortunately, that has not worked (tried it more times than I can count). I’ve been working with Jason K. trying to troubleshoot this problem. He requested that I create a post requesting the feature upgrade.

InRide works just fine. The software on my laptop works just fine. The problem lies with the design of the app, it does not maintain BLE connectivity with the software (with BLE turned on in the app and on the phone, with the Kinetic Fit app closed).

 

 


(john white) #4

I am also have problems with this, sometimes it is fine , other times it will drop for a couple of seconds or even 10s of seconds multiple times in a ride, It is driving me mad. Changed batteries on the inride made no difference. I wish this thing would just work with the bluetooth in my laptop!


(Christopher Haisty (B)) #5

Amen to this.  The Android Mobile Link is terrible at pairing with the InRide (and my Wahoo HR monitor). It’s a total crapshoot when and if it will connect, and rarely does so quickly. Meanwhile, every other app I have an connect without any issues, including direct connection to either my laptop or to my mobile phone.  The issues exist only with Zwift, and are getting so bad Zwift is becoming almost useless.


(john white) #6

Had a hammerfest stage ride totally ruined by the mobile app today, numerous small dropouts on the climb to the finish at Richmond before completely hanging, had to repair with the ANT+speed sensor in the end . Added 6 minutes to the ride and probably won’t count as it was supposed to be with the inride!

Cheers!

perhaps once the IOS lovefest is completed they might show some love to Android , BUT i won’t hold my breathe.

PS had a ticket raised for this weeks ago still not heard anything back


(Jason K) #7

Note : In general, we haven’t seen any outstanding issues with inRide compatibility. Any issues have been the result of BLE connection issues, network/ZML app connection issues, or hardware problems, all of which stem from client-side complications.

The issue Sharon had was resolved back in May 16. 

Christopher - I see you also have a ticket, and we’re working with you there.

John - sorry about the delay on response time. QA has been swamped testing the recent build until now. I just confirmed that they sent you a response to your ticket. The issue appears to be network related so far.

For anyone else having issues, see our troubleshooting articles: