Problems connecting Kinetic Smart Control


(Jim Elsner) #1

Has anyone else tried and is having trouble connecting the new Kinetic Smart Control to Zwift? This is NOT the inRide, but the new Smart Control unit.  It connects through the Zwift Mobile app via BLE (just like inRide), but as soon as it pairs in Zwift and shows up under smart trainers, the Zwift Mobile app closes (crashes) and Zwift looses the connection to the trainer.  If I use an old trainer and my Stages Power sensor, Zwift and the Mobile app work fine.


(Duane Gran [Vision]) #2

I’m using one and it works well with native bluetooth on a mac but I’ve also had the same experience as you where the iOS app crashes if I pair to my windows machine.  I spoke with someone else who reported that app pairing worked with Android.  If Zwift needs some more detail I’m happy to help here.


(Jim Elsner) #3

Duane, thanks.  Zwift responded to me today acknowledging an issue between the app and the Smart Control unit and they’re working on it.


(Michael Britton) #4

Dang it! I have been a KK Fluid trainer for a few years. I was really hoping to get the new smart unit but I’m not sure I want to beta test.


(Jim Elsner) #5

So update as of just yesterday…the updated Zwift app released yesterday and did fix the connection problems. I was able to connect via BLE through the app no problem. However when riding there was no apparent change in reisistance as advertised as slope in Zwift changes. But I want to try a little more and see…


(Jason K) #6

This issue should be resolved for all iOS devices now. Note that this only prevents the ZML app from crashing when paired with the Kurt Kinetic Smart Control. The fix for resistance will be included in an upcoming game update.

Thanks for your patience, all!


(Jim Elsner) #7

Oh good news. Thanks!


(Jim Elsner) #8

I can confirm the latest Zwift update is now correctly controlling the resistance! Thanks!!


(Jason K) #9

Thanks for the confirmation! For anyone else experiencing this, just make sure you have the latest game update. If you’re still having problems, open a support ticket as its more likely to be a setup issue.

Ride On!