Zwift BLE support is broken AGAIN


(Darren Conrad) #1

Well, another week and yet another update that breaks BLE support. Was working great before version 1.0.12103 update was installed. Does anyone test these releases before they get pushed out? Can I get on the testers distribution?

Kinetic InRide sensor is no longer being picked up by Zwift mobile link but my Kinetic Fit app sees it just fine. I have fully disconnected InRide sensor from the Kinetic Fit app and force quit the app but no luck - mobile link won’t see it. I tried deleting and reinstall Zwift mobile link, restarted my iPhone, rebooted my MacBook running Mac OS X 10.11.5.  No change.

Out of desperation I tried to ride with just my bluetooth speed and cadence sensors but the data was so choppy and inaccurate I couldn’t keep the power levels steady:

This is REALLY frustrating especially when Zwift was working great. Now I’ve had yet another terrible workout and am feeling like BLE support will never be solid. Any plans for another update to fix this soon???


(Michael Ziock) #2

Darren, several of us have noticed this issue.  The latest can be found on this thread which indicated yesterday afternoon (PDT) it would be fixed in ~24 hours:  https://support.zwift.com/hc/en-us/community/posts/206844306-Bluetooth-stopped-working

Definitely agree finding these before release would be idea


(Michael Ziock) #3

idea = ideal :slight_smile:


(Eric C. (Zwift HQ)) #4

Hi Darren,

We are aware and are trying to work on a solution. Also, let’s keep it to one thread with the same issue (as mentioned by Michael).

Thanks! :slight_smile: