In Game Calibration

 Yesterday I used the in game calibration feature to calibrate my cyclops magnus. I followed the instructions on the screen and got a ‘success’ message. Immediately after I got the success message, I then unlocked several power achievements, but hadn’t stated riding yet. When I set out to ride the volcano circuit, zwift said I was doing 45MPH at 2000 watts. My trainer is only rated for 1500 watts max. What’s the problem here? 

I used the in-game calibration on my 2017 KICKR Snap. When using ANT+ FE-C on my PC, it timed out. I then tried via bluetooth on my iPad and it worked, but my watts were everywhere while doing a workout in ERG mode and the ERG response to the different wattages was slow and inaccurate. I could tell ERG was on because of the constant resistance, but I had to switch gears up and down to get the required wattages and not fail the workout.

Please fine tune this as I think this is a wonderful addition to the app.

The calibration feature is broken as hell. Someone please tell us how to get rid of the calibration settings and reset to default because it used to work just fine before calibration was added. I’m definitely not able to put out 300 watts in my low gear without trying.

Sorry for the problems with the new calibration feature, everyone. It sounds like there’s still some kinks to work out.

One of our developers has posted a response in this thread, so I’m going to condense the discussion over there and close this one.

Thanks for your patience as we continue developing Zwift!