Cyclops Magnus


(tom gallagher) #1

My Cyclops trainer is giving me fits!  It will not calibrate in Zwift and in Rouvy, it will not link up, although at one time it did.  Last night riding the Tour of Wattopia, my trainer became very hard to pedal on the long uphill and eventually I was passed by 100 riders! When I was almost at the very top of the mountain, it suddenly became very easy to  pedal and I had to switch into my hardest gear in order to generate enough watts to finish the hill.  I abandoned on the downhill.  When I tried to ride this am, Zwift gave me a message that I was super human, or I needed to recalibrate, my wattage was showing 2000 watts during the calibration mode (which would not calibrate).  I have contacted Cyclops in the past, but I have never received any response. Help!  Or is this a lemon?


(Nigel Doyle) #2

Try contacting Cycleops again. If you get no response then post on their Facebook page. You will definitely get a response there. There is also a Facebook user group for Magnus and Hammer trainers. Members are very helpful in problem solving. Cycleops staff drop in from time to time.

Calibration is best done in Rouvy. Often when calibrating in Zwift you’ll get a time out error. If it won’t calibrate in Rouvy then you could have a dud and it needs replacing. With Rouvy you can also update the firmware. Make sure you’re on the latest version.


(tom gallagher) #3

Thanks for your response!  I tried every thing as far as the software/firmware.  Nothing would load in or repair the problems.  For some time I was able to calibrate in Rouvy, but never consistently in Zwift.  I contacted the store where I purchased the Cyclops trainer and I was able to return it and replace it with a Kickr Snap.  The weather in my area finally changed to warm and sunny, so I was mt biking this weekend and I have not hopped on the new trainer, but I was able to calibrate it quickly.  I desperately wanted the Cyclops to work, I love to support US products and I do ride in Wisconsin, but the backup support is lacking.


(Steven D) #4

Hi Tom,

It sounds like you may be experiencing problems as a result of this known bug in the game. The recommended workaround is to calibrate your smart trainer through Rouvy.

If you’re not able to Calibrate your smart trainer through Rouvy, that is somewhat alarming and it sounds like you really need to talk to tech support from CycleOps. 

Try this link: https://www.cycleops.com/page/support/contact

You’ll find a support phone number there, an email address to contact them, and a way to submit a ticket for support. The choice is yours.

If you’re able to get help from CycleOps, properly calibrate your smart trainer through Rouvy, and find that you’re still having problems in Zwift, please submit a support ticket and one of our Zwift support team members will be happy to further troubleshoot this issue. 

EDIT: Seems like you went with a Wahoo smart trainer, but my previous response is applicable if you ever encounter similar issues with a CycleOps smart trainer in the future. Thanks!