Calibration fail

Lately Zwift calibration fails to work. It either freezes on the way up, or spins up to 23mph, then tell me to stop pedaling, and then it freezes on the way back down, usually at about 5mph, then it says Failed. I have tried all the usual fixes (unplugging/restarting all the things, etc), and I was unable to get it work today. When I tried to go ahead with my ride today anyway, the resistance and watts were wildly inaccurate. I finally had to end the ride.

For reference, this is a CycleOps Magnus trainer that I bought from my bike shop in November, and it was working fine until the last week or so. I’m using an AppleTV device, and run Zwift companion on my phone at the same time.

Use the free Rouvy app to calibrate Cycleops trainers.

Thanks! I did hear back from CycleOps about it. He said it is possible to use free Rouvy to calibrate and then close Rouvy out and the Magnus will retain the calibration when you log into Zwift. If that works, it would be great. I really enjoy Zwift otherwise.

I’ve had similar problems with ATV and my Wahoo Kickr.

I just calibrate with the Wahoo app instead and haven’t had any problems.

The calibration is stored on the Trainer so you can calibrate with Rouvy or the Trainerroad app like what I use. Zwift has known issues with Cycleops trainers and is pretty unreliable.

Thanks! I heard back from CycleOps as well, and as long as I can calibrate on Rouvy for free, I’m good with this.

Doesn’t Cyclops provide a calibration utility?

1 Like

No. Rouvy has an association with Cycleops.

You can however upgrade the firmware using a Saris utility app.

Odd. Not what I would expect.

Elite Suito and Zwift. Calibration. Push above 50Km/h and calibration went fine.