I want to be able to use the gears on my bike

I have not done much on Zwift the past 2.5 years. I went back out for a short ride, recently, after updating everything. When I shift the gears on my bike (Trek - Domane) I would like to feel the pedal resistance change. The only thing that seems to change the resistance is the inclines. It really doesn’t seem to matter what gear I am in the only way to increase watts is spin faster. Does any have some suggestions so you can use a regular bike and a Wahoo Kickr smart trainer. Thanks for any suggestions.

The kickr connects to zwift by pairing Cadence and Controllable. I assume you are not riding in ERG mode as cadence is altering your power. Is Controllable pairing with zwift?

I can’t see how changing gear would have no effect if you are riding in sim mode? if the gradient doesn’t change zwift would not alter the resistance you feel.

is there any chance something else is controlling the trainer? a phone or bike computer or anything?

Trainer diffulty slider all the way right on a fully working smart turbo would make you use more of your gear range, on an up and down route.


I set the controllable to the Wahoo Kickr and it pairs just fine. ERG mode is not on and I don’t think it is available when riding a normal route. Thanks

I can’t find where the Wahoo Kickr is connected to anything else. When you say sim mode is this the same as ERG mode?


Hey Mark. What device are you running Zwift on?

Have you paired the trainer with any other devices, ever? (smartphone, sport watch etc) If so, I’d start by “giving the other devices amnesia” - unpair and forget the trainer from all of them.

If you’re on a PC, uninstall Zwift, track down the folder it stores data files in and delete it before reinstalling. Sometimes there are corrupt files left over.

EDIT - Sim is the opposite of Erg mode. Sim would make the trainer “simulate” road gradients where “erg” adjusts resistance based on a programmed workout.

1 Like

I’m still struggling to get my head around what the problem is.

Are you saying if you are cycling in free ride mode (that is what I meant by sim mode btw) and you change to a harder gear your trainer somehow compensates so that it isn’t any harder to pedal?

I can’t work out how that could happen unless something else is controlling the resistance on your trainer. Do you have a garmin head unit or similar? They can control a trainer and might be keeping you at a certain wattage?

that is all I can think of. Zwift and your trainer would have no idea what gear you were in or when you changed.


I have a Trek Domane with a Stages left crank power meter. I also use a Garmin head unit when I am riding inside. When I shift into a harder gear on flat ground there are a few seconds of adjustment and the resistance then seems basically the same. The only way I am able to get the watts up is by spinning faster. I agree this makes no sense. When I do come to an incline or climb the watts go up but I think this is controlled by the Wahoo Kickr I use. When you ride your bike what do you set as the controllable?

I am going to take this off my iphone and see if that makes any difference. CJ when you start a regular ride using you bike how do you set this up? What do you select as your controllable? What do you set for the other input variables.

I have a Wahoo Kickr, a stage power meter and a wahoo heart rate monitor.

You need to pair your Kickr as the controllable device.

What are you using to connect everything - Bluetooth or ANT+? It sounds like you have multiple devices trying to control the trainer somehow.


if you spin faster that is effectively the same as changing to a harder gear - it will make the fly wheel spin faster.

do you pair your trainer as controllable in zwift? if not you do need to. Do you pair your trainer to your head unit? if so don’t do that. It might be that zwift and your head unit are fighting over which controls your trainer

1 Like

Try leaving your Garmin turned off. Connect the Kickr as Power, Controllable, and Cadence. Then connect the Tickr for HR.

If this gets it working, then you may have the Kickr paired to both the Garmin and Zwift as controllable and it’s getting confused.

Assuming you are wanting to record your ride with power from your Stages PM on your Garmin, you should be able to do this as well. Just disable or delete the controllable connection from the Kickr in the Garmin’s settings.

That’s another piece of the puzzle.

I’m with Mark: it sounds like multiple devices are attempting to fight for control of your trainer. (hence my suggestion to “give them all amnesia”) Shutting all devices off except the one running Zwift would do the same thing - make sure nothing is trying to steal control from Zwift.

If you still want to MONITOR your power on the Garmin Edge, go into the Garmin Edge device settings, find “Sensors & Accessories”, go to the “Controllable Trainer/Smart Trainer” and select it to “OFF”. This way, the Edge isn’t trying to take over control.

I did what you suggested and used the wahoo kickr as the power and the controllable. It really didn’t make much difference. I shift to my highest gear and then back off 2 times and rode Volcano Flat and some extra for a total of 15 miles. On the flats I never shifted out of my big gear. The only time I did any shifting was on some of the small climbs. I would bring it down another 1 - 2 gears and once the small climb was over go straight back to my big gear. So right now shifting gears on my bike does nothing on the flats. The only time they have any effect is when there are some type of incline. I really can’t figure this one out.

Thanks for the suggestion.

Something is still very wrong here. If you’ve checked that no other devices could be connected to your trainer (phone, Garmin etc) by having them turned off then I would try with a trial version of RGT or other software to see if you have the same problem.

It could be a trainer fault.

1 Like

i still don’t really understand your problem.

what do you want to happen when you change gear on the flat and what does happen?

Same response from me to the OP: what you’re citing as abnormal behaviour from the KICKR sounds like it’s doing what it’s supposed to. What do you perceive as having changed?
I’ve gone into your saved/visible rides over the last year and looked at the power, cadence and heart rate. They show realistic variations and are within the bounds of what’s expectable for the terrain ridden.

If you change to your smallest front chainwheel and one of the largest rear cogs while riding on the flats, do you not spin out, or at least feel far less resistance compared to the large chainwheel and smaller rear cogs?

Is your weight that is entered in Zwift correct?

As someone mentioned earlier in this thread, what is your trainer difficulty slider setting? The Zwift default is around the midpoint; moving it fully to the right will give the most realistic experience/effect with respect to changing and needing to change gears.

Failing everything else, what model of KICKR do you have, exactly? Is the firmware up to date. If it’s the same one you’ve been using since late 2018, is it possible that there’s an issue with the trainer? Have you contacted Wahoo to check that it’s still functioning correctly according to their diagnostics?

He seems to be saying that shifting gears seems to do nothing on the flat. Changing Trainer Difficulty won’t make any difference with that. It should be that changing several gears up/down on the flat (not in ERG mode) significantly changes the effort required, but he seems to be saying that this doesn’t happen (only on hills).

I don’t think it has anything to do with the trainer. There is no way for the trainer to know when you switch gears in sim mode. (ERG is different in that it will try to keep constant resistance)

@MARK_LITTS try riding on tempus fugit in your biggest front and small rear for 5 minutes then change to small front and big rear and do another 5 minutes. Keep the cadence the same. Do this a few times and share the link to the strava activity.

I am sure you will see a big speed difference.

1 Like