HR strap - No signal (Bluetooth/Android)


I have been having trouble pairing the HR sensor (Bluetooth connection) for a long time. On the pairing screen, the trainer (PWR, CAD, Controllable) jumps in, but with the HR sensor, sometimes I have to be patient. Mostly I have to select it manually and then I get “No Signal” for a few minutes. In 90% of situations, the problem is solved in a few minutes, but unfortunately it happens that you have to restart Zwift, which in the case of the roller trainer (Elite Nero) is a bit problematic.

When the connection with the HR strap is established, the whole thing works stably and smoothly - there are no jumps in the indications.

I soak the belt before each use.

Previously I used a Garmin belt, but when the problems started (as above) I bought a third-party belt - the problems occur again.

As you can easily guess, if I want to change “World”, I have to go through the pairing process from the beginning. Drama.

The HR strap is easily detected by the Wahoo Headwind - ANT+ connection (in seconds), or the Wahoo Roam and Garmin Edge 1030. The battery in the sensor is fresh, the connections are clean (no corrosion) and the electrode strap itself is washed at least once a week week.

Rarely, the problem is with the trainer - it happens.
It used to be a problem, but it has gotten worse over time.

Zwift is always updated to the latest version, and I run the whole thing on Xiaomi Mi Pad 5 Tablet - Android 12 (MIUI 13.1.3)

Any ideas? The problem is clearly related to Zwift/Android.

Best for you Zwifters