How in the H#ll do I get hold of these guys

Sorry for the language. I’m just a little pi##ed right now. Since the update I constantly get dropped on multiple devices and using both my power meter or trainer. I have tried to get hold of these guys and all I seem to get is the questions page. (Does this help?) No! ok here is a different answer which is also jot helpful. Any info would be greatly appreciated. As right now I can’t get more than 5 mins into a ride. Tony

We need more info.

Guide to Getting Useful Support?

1 Like

What do you need buddy?

Everything, all the details you can give. Check out the post Gerrie linked.


Hey so I was originally using my old Mac Pro. Which has all the latest updates, connection via ANT To My Saris H3 trainer. I had a few similar issues months ago that seem to fix themselves. Originally after the latest update I would get approx 40 mins into a ride then get dropped and could not reconnect. I went to the saris app and checked my trainer, connected straight away and diagnosed. All up to date. Two days in a row this happened. So I decided to connect to my IPad via Bluetooth again using my trainer. Same thing. This time I connected my stages power meter and finished the ride. I rode like this a couple days without any major issues other than the companion app wouldn’t connect. Yesterday I connected with my trainer again got maybe 4 mins into a ride and dropped. I thought F##k this and tried to connect to my stages. Wouldn’t even pick it up. Went to both my stages app and Saris both connect and picked up straight way. I unplug everything, restart. Same thing 4 or so mins in and dropped plus I can’t reconnect. No ride for me ughhhhh.
I did read the link Gerrie sent and re uploaded/ updated all my apps from the App
Store. Will try this today to see if it helps.
So anyway I go online to try and contact Zwift also reading some posts about issues since the update. All I got was sent an answer that didn’t help. Then just rerouted to other non helpful answers lol. If you need anything else please let me know. Phone is an IPhone 10x. Latest software. Tony

Did you put your log file in to look for dropouts.

I did send the log. But the link you quoted comes up as invalid. So I retried and got 49.31 mins in before being dropped again

Maybe this old Video helps…

What link? the link?