Has anyone managed to complete a workout on an iPad?


(Graham Collier CCC) #1

I have tried 6 workouts now and a free ride and they all crashed/closed during the last quarter. You get the option to continue but it never works! I have submitted a support ticket with log files but have had no help.

Are other people getting the same problem?

I really want to get this working.

 

 

 


(Jon Mayfield) #2

Hi Graham, sorry to hear of the troubles.  We have thousands of successful workouts logged on iOS every day, however we do know of a current bug that especially affects certain iOS devices like an iPad Air and iPhone 6 which may cause the issue you’re experiencing.  We’ve got a potential fix ready to get into the app store, and we hope to see it be available within the next 4-5 days.

Aside from the 7 day trial, we do allow a free 25km/month free on Zwift with no subscription necessary, so I hope you’re able to give it another try once this (hopeful) fix goes live.

Sorry for the inconvenience.


(Alex Boyce) #3

Same problem a few times for me too (though not every ride - is it a battery thing as I was down to about 20% when it crashed??), so relieved to hear there’s a fix coming (I’m using iPhone 6 on iOS 10.2.1). I just hope the fix comes sooner than 4-5 days. My ride exists in my activity log, but it didn’t sync to Strava which I was looking forward to as I really put in a big effort on the mountain as the only hard section of the ride. I’ve followed the FAQ’s to get the activity files and submitted these with a ticket to see if the Zwift engineers can do something. Fingers crossed.


(Graham Collier CCC) #4

Hi Jon,

Thanks for your response. I am using the iPad Air, so I’m glad you are aware of the issue and working on a fix. I will keep checking the app store for updates.

I really hope this fixes the issue as Zwift is a great training aid when its working. I am currently paying for a subscription and have really only had this problem since the last app update.

cheers

Graham


(Richard Gandy PRS C) #5

Hi

 

I’ve experienced two crashes out of about 10 rides, I was able to recover the last ride and import it manually into Strava although it does say partial ride. Hopefully the fix will be available soon. Thanks


(Rune Horrigmoe) #6

I have the same experience with my ipad - very very irritating!!! 


(Laura Anderson) #7

I’m having the same problem with the iPhone6 on my last several rides. I’ve had it happen in group rides, workouts, and just regular rides. It always happens at around the 1 hour mark.


(Jon Mayfield) #8

The update is out now in the App store which should increase reliability, especially for the crashes that were happening 30-60minutes in.


(Bruce Crowe) #9

I have had problems with iPad app crashing, but only when I’m in an event.  It’s fine when I’m free riding or in a workout.  Will this update fix my problem?

 

thanks

 


(Graham Collier CCC) #10

App updated…

I have now successfully completed a 1 hour 10 min Tempo workout. :slight_smile: No crashes or glitches and upload to Strava also worked. Please say thanks to your team!

Zwift is a great app, I hope it keeps working…

thanks
Graham


(Richard Gandy PRS C) #11

I’ve now manged to save a couple of rides without incident (using latest version) so fingers crossed all good now. Thank-you.


(peter spruit) #12

I had a crash in Watopia today at exactly 25 km. I logged in with my paid account. My Iphone 7 plus 128 gb froze. I couldn’t kill the app or turn off my phone. But after a while it unfroze. But i had to kill the app. I did the figure eight ride. The workout wasn’t saved. I am on the latest ios and zwift app version.

 

 


(Luis Vertigo) #13

Still having crashes on iPhone 6
Rather disappointing because otherwise Zwift is fun


(Dave Thomas) #14

My IOS app (on iPad Air 2) crashed about 30 minutes into an FTP test last night.  A few minutes prior to crashing the image quality deteriorated.  Are others still experiencing the problem?


(Oliver Sirrell) #15

iPhone 7 , the Crashes are getting worse. First one about 1week into having the app. last week another. last night 3x !!

I now screen shot any decent recording as im starting to get the P taken out of me when I say … oh I just did 50miles , guess what I was just 4th on a sprint and fastest out of us all (our group). but it crashed and no data… yeah yeah lol.

I can almost laugh but it is starting to grind on me now. Zwift please sort ASAP


(Richard Jodoin #HauteRoute_Asheville) #16

Hi. Same thing is happening to me. Using iPad updated to the latest iOS version. Zwift is also kept up to date. Someone mentioned that perhaps low batterie level might be the culprit. My battery started at 45% and quickly went down in the 30% range. Zwift sure sucks the life out of the iPad battery. I plugged the iPad in when battery reached 34% and it stayed steady from that point on. Wonder if the battery needs to be at high level to avoid crashes. Hard to say but I hope Zwift folks are looking into scenarios that could cause crashing. Worst part is that when I relaunch Zwift app the system offers to continue the ride I was on but it always fails. Sucks.


(Jennifer Sirrell) #17

I thought the battery issue myself when I was on 20% when it originally crashed. The last time it crashed 3x in a row was on a full battery and plugged in during my ride (as always now) so unfortunately I don’t think the battery is related, not in my case anyways. ATB


(Jennifer Sirrell) #18

Sorry the above comment is from Oliver, just realised it’s auto signed into the wife’s account lol