Half of My Action Bar Does Not Work


I have Zwift running on Apple TV and on Pixel 2 Android Companion app (for the extra BLE sensors). Half of commands on the companion app do not and have never worked for me. This includes the inability to flick my elbow, the inability to display the watts per kg/RPM graph at the bottom of the screen, and when I try to give ride ons to friends while riding my avatar will say ride on when I do press the thumbs up but no ride ons are actually given. I cannot get these commands or the graph to show when I try on either just Apple TV on its own with the remote, on the companion app while also connected to Apple TV, nor can I get it to work on my iPad. Has anyone ever experienced anything like this. I find it strange that some things work on the Action Bar such as waving at people for me and while other things do not. Any help would be appreciated!


Hi @Bartosz_Orzel

Welcome to the forum.

The rideon button does not give ride ons, the avetar just say rideon.

It is strange that some does not work.

1 Like

Hi Gerrie,

Thank you for the response. How do you give ride ons mid game while you are riding then?

Any ideas on a possible fix for the graph to display?


I don’t use ATV so can’t speak to using the ATV remote to do anything.

The companion app on your phone: during a free ride (not an event or race) on the map let the circle around your dot/triangle complete and then tap the circle, that will give a ride on to each person in the circle. Otherwise use the app to find zwifters near you or zwifters you follow, click their name, scroll down and click the ride on button.

You are probably right that the flick elbow doesn’t do anything but another explanation is that the movement is subtle and probably delayed.

The HR graph at first is tiny and far on the left until a few minutes have elapsed so try further into the ride.

Can’t help you more than that.

I use an Apple TV, MacBook Pro, or iPhone depending on the day and circumstances.

  • The graph works fine on all of them.
  • Thumb up button doesn’t give a Ride On. It makes your avatar say “Ride On”.
  • The hammer, the toast, and the smiley also give audibles (“Hammer time!”, “I’m toast”, “Nice”).
  • Elbow flick - I will double check this one later today. I did notice when on the mtn bike a few weeks ago, that it did not work. I was not sure if it was because I was on the mtb or if there was a new bug.
  • The bell - You will hear a bike bell.

Make sure your Apple TV OS is updated. Make sure your Zwift app is updated. Lastly make sure your Companion app is updated.

The Companion app also needs to be on the same WiFi network as your Apple TV.


I had a Zwift session this afternoon using my Apple TV 4K w/Companion app on iPhone 8. Both are updated to latest TV OS and IOS respectively. Also, both are running the latest Zwift and Companion app respectively. Trainer is NEO.

All buttons (i.e., Ride On, Graph, Hammer, Bell, etc.,) on both the Companion app or directly via the Apple TV remote worked as expected. This includes the elbow flick. If you have an item/power-up (e.g., aero boost, feather, etc.,) the elbow flick will be replaced with an action to throw the item away.

Again, everything worked from both the Apple TV remote and the Companion app.

Double check everything is updated. Force quit Zwift and the Companion app after each session.

1 Like