Companion app not showing option for ride ons


(Lindsay Cripps) #1

Using the companion app in conjunction with Apple TV.

If you select the icon on the map showing your location it’s meant to send rideon’s to riders that are close. Sometimes it shows with the circle around your location icon other times there’s no circle so it’s disabled. Is there a reason? Otherwise the companion app work ok.


(Lin Alan) #2

If you are part of a group ride or race, that function is disabled. In such a case, if you wish to give out a “Ride On”, you will need to do so manually by selecting the rider dot on the map or by going to to the “Zwifters” (or is it “Nearby Zwifters”), selecting a rider name and then hitting the “Ride On” button.

If you are not in a group ride or race, try restarting the companion app.


(Lindsay Cripps) #3

No I’m not on a group ride or race but on a free ride. It works sometimes but closing and restarting the companion app doesn’t help. Using an Apple TV and an iPhone for the companion app.


(Lin Alan) #4

I’m also on AppleTV w/an iPhone. I’ve only once had it do as you described. A complete restart of the companion app fixed corrected the issue. Perhaps double check that your companion app and Zwift are both up-to-date.


(Lindsay Cripps) #5

Yep done all that Lin no change. May work one time out of ten if I’m lucky.


(Roman Kuhn) #6

It has something to do with your zoom. I found out that I can not give Ride Ons when the map is to far away. By zooming in I was able to give ride ons. You can zoom in by hitting the symbol on the right. Give it a try and let me know if it worked.


(Lindsay Cripps) #7

So inconsistent. Rode NY this morning worked ok. RIde NY tonight doesn’t appear no mater what I do. Tried closing the companion app and re opening zooming in and out. Nothing helps. Raised a ticket on this a few days ago. Heard nothing. No other intermittent issues connecting.


(Vincent W.) #8

Investigating!