Group Workout Issues

When I join a group workout I am not getting the workout instructions or the workout box showing need to speed up or slow down. As as result it is like a group ride but I have no idea when to speed up or ease up.

If I do a solo workout, all is fine.

Has anyone else had similar issues? I have double checked and I am on the latest version of Zwift which I am running on windows.

Thx JT

It’s 100% a group workout you’re joining?

Do you have a link to the event?

Do you use the companion app at the same time?

Are you all wearing the same jersey?

Hi Stuart

Yes proper Group Workouts. I checked in advance the profile of the workout and they are identified on Companion App as a group workout.

The companion app will have been running at the same time. I always tend to have it on when I am riding.

Yes, the 4 times I have tried since the weekend I was wearing the group workout Jersey.

I’m not sure how to get links to past events and I didn’t save them when I quit. I know I tried the Mountain Massif workout tonight (I’ve done these in the past without issue) at 5:15pm and the Team Italy Workout at 5pm (both UK time) this evening.

Last weekend I tried the Power Party Fitness Jumpstart workout on both the Saturday and the Sunday.

I thought at first in my have had something to do with my Firewall as I was having connection issues too. However, I have disabled them all and still had the same issue tonight.

The problems seem to have occurred since the last update.

I should add I am having no other issues with Group Rides or Pace Partners or solo workouts. Just the Group Workouts.



I don’t have a solution for you JT, however I have the exact same problem. Individual workouts are fine but any group workout I join I have no interval screen and just blindly riding!

It is a work PC. I read somewhere that there maybe issues related to the way Zwift writes log files but I’m no expert. Did you manage to resolve this? Ben.