Graphics Performance - ThinkPad P52


(Pierre Goyette) #1

So I received my new ThinkPad P52 laptop and quickly installed Zwift to see the 3D performance. I changed the resolution to 1080p in the settings. I could not see the two higher options.

I analyzed the log file and Zwift is refusing to go above the medium profile.

This laptop (ThinkPad P52) has a new XEON E-2176M hexacore with 32 GB memory, an Nvidia Quadro P2000 video card with 4GB ram running Windows 10 x64 1803. The screen is a 4K 3840x2160 (60Hz) screen. It is a laptop designed for 3D work. I changed the two recommended settings for NVidia for the best performance. It never chooses a profile above medium. And this video card has a performance benchmark 50% better than those recommended for 4k support.

I copied the ‘ultra.txt’ profile over to ‘medium.txt’. The log file analyzer shows a resolution of 1080, shadow res 2048 with an average frame rate of 89. OpenGL 3.1.0. It all runs perfectly.

So why will it not choose a higher profile or allow a higher resolution. Whether the display scaling is set to 100% (full 4K) or 200%, I never see any other options or changes in the chosen profile.

Any ideas ?


(Vincent) #2

Sorry to hear that Pierre! Can you share a screenshot of your resolution drop down?


(Pierre Goyette) #3

First, I reset the profiles in the data\configs folder to stock values. This is what it shows:

Then, I analyzed the log file from the settings above. This is what I got. I don’t understand why Zwift keeps using the ‘medium’ video profile instead of high or ultra.


(Vincent) #4

@Wes May be able to help with this one :eyes:


(Gerrie Delport TeamODZ) #5

My guess would be that the P2000 is not listed as one of the GPU’s that can run at ultra, since it is more for 3D graphics like CAD 3D and so on not really made for gaming. I search a few gaming sites to see if this GPU is listed but could not find any that tested it.


(Pierre Goyette) #6

Well, let’s forget Ultra. I think my hardward definitely has the horsepower for it but why is Zwift using the “medium” profile ? I have an avg 120 fps with a high powered video card. The choice of profile, I assume, is chosen based on what it can do, not whether it is on a list or not.

So back to the first question. Why is Zwift defaulting to the “medium” graphics profile ?


(Wes) #7

I’ll need to check with the dev team to find out what may be triggering the medium profile default. For reference, if you override the profile to high or ultra, do you still manage high frame rates or does it drop below 30?


(Pierre Goyette) #8

If I copy ultra.txt over to medium.txt and restart Zwift. All works well. Frame rate is something above 80 fps. I don’t see any problems or lags.


(Eric C. (Zwift HQ)) #9

Hi Pierre,

The Quadra is a 3D card built for graphics rendering for graphics creation, not game playing. It’s powerful but just has the wrong profile associated since it’s generally not considered for game performance. I can flag this up so that it can be added to the Ultra profile.


(Pierre Goyette) #10

Just as a final update. I reinstalled my laptop clean to Windows 10 x64 17758 (RS5 for 1809). Set all the Nvidia tweaks, COPIED Ultra.txt to Medium.txt. Enabled gShowFPS.

Zwiftalizer shows:

Profile - Medium
Resolution - 1080
Shadow Res - 2048
AVG FPS - 99
MIN FPS - 78
MAX FPS - 107

I see no errors or problems with the display.


(Gerrie Delport TeamODZ) #11

@Pierre_Goyette: The way I understand how Zwift assign different profiles is by looking and the GPU model and then have a lookup to a table with tested GPU’s. (I get this for following this forum for the last 3 years LOL :relaxed:)

Since your GPU may be good for 3D rendering it may not be good for gaming. It may also be that Zwift did not test that GPU yet since there are very few people using that GPU for Games and even less for gaming.


(Eric C. (Zwift HQ)) #12

The Quadro P2000 is a bit below the 1060 GTX re: benchmarking for gaming so it might struggle with Ultra but do fine with High.

EDIT: Well, there’s something we need to fix: there’s a link under ‘benchmarking for gaming’ but it’s not changing color, so here’s the link: https://benchmarks.ul.com/hardware/gpu/NVIDIA+Quadro+P2000+review


(Eric C. (Zwift HQ)) #13

EDIT #2: Spoke to dev and they’ll add it in to the profile and hopefully by next update :slight_smile:


(Pierre Goyette) #14

@Eric. Cool. Many thanks. Last question Why is the max resolution limited to 1080 ? Is this due to the medium profile ? I have a 4K screen… even if I set the windows scaling to 100% (aka super tiny fonts), Zwift only shows 1080 resolution.


(Eric C. (Zwift HQ)) #15

Yes, this is because of the profile.


(Jon Edwards) #16

Sorry to revive an old thread, but I am having a similar issue. I just got a new HP 690 with a Ryzen 5 2400g processor. This processor includes an integrated gpu (the AMD Vega listed on the zwiftalyzer screenshot). Is Zwift setting my graphics profile basic because of this, instead of the 4gb Radeon RX 580 GPU? The HDMI is plugged into the graphics card output and task manager shows it is using the Radeon’s memory. This unit was to replace running zwift on a macbook and I hoped for better performance.


(Jon Edwards) #17

@Pierre_Goyette, are you describing a way to overwrite zwift’s chosen graphics profile? If so, do you know if it still works? I am facing similar issues with zwift choosing a basic profile for my new desktop. Thanks!


(Pierre Goyette) #18

@Jon_Edwards, yes. My first post shows how to override the video profile. He are two links which will be useful:

https://kb.zwiftriders.com/tuning-maximum-gpu-performance-mac

Then, you can use the Zwiftalizer to show the performance of your current profile.

If you have questions, problems, let me know…


Zwift is recognizing the wrong GPU
(Jon Edwards) #19

Thanks @Pierre_Goyette. I got it to work! I had to jump through some hoops to give myself permission to save in the configs folder, but figured it out. Do you know if when zwift updates the basic file will be reset? Thanks again, I was so frustrated having just bought a pretty decent new computer.


(Pierre Goyette) #20

@Jon_Edwards You’re Welcome. In terms of Zwift recognizing your GPU properly. They did not design the software to automatically evaluate the hardware platform and then pick the correct profile. Known hardware is associated to certain profiles. So, I would suggest that you open a ticket with Zwift to get your GPU added to a certain profile. You will need to know the avg frame rate for each profile. This will help asses what base profile should be assigned to your GPU